# CVE-2026-55761: Portainer: Unauthenticated Restore Endpoint Allows Admin Takeover on Uninitialised Portainer Instances

> Unauthenticated attackers can take over uninitialized Portainer instances by accessing restore or admin init endpoints during the setup window.

- **Severity:** High 7.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:L/VA:N/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 8 Jul 2026
- **Also known as:** GHSA-x626-fcwx-f5pc, GO-2026-6324

## What is CVE-2026-55761?

CVE-2026-55761 is a high-severity authentication bypass vulnerability in portainer, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Portainer Community Edition is a lightweight service delivery platform for containerized applications that can be used to manage Docker, Swarm, Kubernetes and ACI environments. In versions 2.39.0 through 2.39.3 and 2.40.0 until 2.43.0, unauthenticated restore and administrator initialization endpoints (/api/restore and /api/users/admin/init) remain accessible during the five-minute setup window for uninitialized instances, allowing a network attacker to restore a crafted backup or create the first administrator account and gain full administrative access. This issue is fixed in versions 2.39.4 and 2.43.0.

Weakness: CWE-287 (Improper Authentication)

## Which versions are affected by CVE-2026-55761?

5 open source packages ship an affected version, including github.com/portainer/portainer. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/portainer/portainer` | Go | All versions | None |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.4 |
| `github.com/portainer/portainer` | Go | From 2.39.0 | 2.39.4 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.43.0 |
| `github.com/portainer/portainer` | Go | From 2.40.0 | 2.43.0 |

Products: Portainer Portainer.

## How do I fix CVE-2026-55761?

Upgrade github.com/portainer/portainer to a fixed version for your release line: 2.39.4 or 2.43.0.

## Is CVE-2026-55761 being exploited?

There is no known exploitation of CVE-2026-55761 in the wild and no public exploit code.

## Other vulnerabilities in portainer

- [CVE-2019-16872](https://insights.sbomify.com/CVE-2019-16872/): Missing authorization in n/a (critical 9.9)
- [CVE-2022-24961](https://insights.sbomify.com/CVE-2022-24961/): Missing authorization in n/a (critical 9.8)
- [CVE-2020-24264](https://insights.sbomify.com/CVE-2020-24264/): Missing authorization in n/a (critical 9.8)
- [CVE-2018-19466](https://insights.sbomify.com/CVE-2018-19466/): Information disclosure in n/a (critical 9.8)
- [CVE-2018-19367](https://insights.sbomify.com/CVE-2018-19367/): Auth bypass in n/a (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55761 and fix it if it is affected.

What it is: CVE-2026-55761 is a high-severity authentication bypass vulnerability in portainer, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55761 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/portainer/portainer (Go): affected all versions; no fix listed
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.4
- github.com/portainer/portainer (Go): affected from 2.39.0; fixed in 2.39.4
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.43.0
- github.com/portainer/portainer (Go): affected from 2.40.0; fixed in 2.43.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55761/ (Markdown: https://insights.sbomify.com/CVE-2026-55761/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55761
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55761
- OSV: https://osv.dev/vulnerability/CVE-2026-55761

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55761/
Summaries are generated and may contain mistakes; the official description above is the record.
