# CVE-2026-55765: Information disclosure in cloudnative-pg

> Privileged tenants can recover superuser passwords from pg_stat_statements to achieve remote code execution in the database pod.

- **Severity:** High 8.5 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 25 Aug 2026
- **Also known as:** GHSA-w3gf-xc94-wvmj

## What is CVE-2026-55765?

CVE-2026-55765 is a high-severity vulnerability in cloudnative-pg, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.28.4 and 1.29.2, CloudNativePG embedded cleartext role passwords in `ALTER ROLE` and `CREATE ROLE` statements generated by SetUserPassword in pkg/management/postgres/utils/roles.go and appendPasswordOption in internal/management/controller/roles/postgres.go. When pg_stat_statements was preloaded with track_utility enabled and an untrusted tenant held pg_monitor or pg_read_all_stats, the tenant could recover platform-managed superuser or application-owner passwords, reconnect through enabled superuser TCP access, and execute operating system commands in the database pod with `COPY ... FROM PROGRAM`. Clusters using SCRAM-SHA-256 verifiers in managed-role Secrets were not affected. This issue is fixed in versions 1.28.4, 1.29.2, and 1.30.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-256 (Plaintext Storage of a Password)

## Which versions are affected by CVE-2026-55765?


## How do I fix CVE-2026-55765?

Upgrade to a fixed version.

## Is CVE-2026-55765 being exploited?

There is no known exploitation of CVE-2026-55765 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55765 and fix it if it is affected.

What it is: CVE-2026-55765 is a high-severity vulnerability in cloudnative-pg, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55765 in the wild and no public exploit code.

Affected product: cloudnative-pg. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55765/ (Markdown: https://insights.sbomify.com/CVE-2026-55765/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55765
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55765
- OSV: https://osv.dev/vulnerability/CVE-2026-55765

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55765/
Summaries are generated and may contain mistakes; the official description above is the record.
