# CVE-2026-55766: guzzlehttp/psr7: CRLF Injection in HTTP Start-Line Serialization

> Attackers can inject CRLF characters into HTTP start lines, potentially smuggling headers or bypassing security controls in applications using this PHP library.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 23 Jun 2026
- **Updated:** 23 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-55766, GHSA-vm85-hxw5-5432, MINI-8mpm-qhjm-9x9c, MINI-925x-6p24-wjvj, MINI-c292-gfhg-xpm8, MINI-p886-mfv8-8hgr, MINI-qv6v-pxgv-f7p6, MINI-rgx6-x39m-38jm, MINI-vh88-5vrq-vwjh, UBUNTU-CVE-2026-55766

## What is CVE-2026-55766?

CVE-2026-55766 is a medium-severity vulnerability in guzzle psr7, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

guzzlehttp/psr7 is a PSR-7 HTTP message library implementation in PHP. Prior to 2.12.1, guzzlehttp/psr7 did not reject CR/LF characters in certain first-party HTTP start-line fields: the request method, protocol version, and response reason phrase. If an application placed attacker-controlled data into one of those fields and later serialized the PSR-7 message as raw HTTP/1.x, for example with Message::toString() or an equivalent serializer, the serialized message could contain attacker-controlled header lines. The issue can also be reached through Message::parseRequest() or Message::parseResponse() when malformed raw messages are parsed into first-party PSR-7 objects and then serialized again. Creating or modifying a Request, Response, or other PSR-7 object alone is not sufficient. The issue requires the malformed message to be serialized and written to the network, forwarded, replayed, or otherwise processed by software that does not independently reject the malformed start line. This vulnerability is fixed in 2.12.1.

Weakness: CWE-93 (Improper Neutralization of CRLF Sequences), CWE-113 (Improper Neutralization of CRLF Sequences in HTTP Headers)

## Which versions are affected by CVE-2026-55766?

2 open source packages ship an affected version, including guzzlehttp/psr7. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `guzzlehttp/psr7` | Packagist | All versions | 2.12.1 |
| `guzzlehttp/psr7` | Packagist | All versions | 2.12.1 |

Products: Guzzlephp Psr-7.

## How do I fix CVE-2026-55766?

Upgrade guzzlehttp/psr7 to 2.12.1 or later.

## Is CVE-2026-55766 being exploited?

There is no known exploitation of CVE-2026-55766 in the wild and no public exploit code.

## Other vulnerabilities in guzzle psr7

- [CVE-2026-48998](https://insights.sbomify.com/CVE-2026-48998/): guzzlehttp/psr7 has Host Confusion via Authority Reinterpretation (medium 5.3)
- [CVE-2026-49214](https://insights.sbomify.com/CVE-2026-49214/): guzzlehttp/psr7 has CRLF Injection via URI Host Component (medium 5.3)
- [CVE-2026-59882](https://insights.sbomify.com/CVE-2026-59882/): guzzlehttp/psr7: Host Confusion via Weak URI Host Validation (medium 4.2)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55766 and fix it if it is affected.

What it is: CVE-2026-55766 is a medium-severity vulnerability in guzzle psr7, published on 23 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55766 in the wild and no public exploit code.

Affected packages and fixed versions:
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.12.1
- guzzlehttp/psr7 (Packagist): affected all versions; fixed in 2.12.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55766/ (Markdown: https://insights.sbomify.com/CVE-2026-55766/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55766
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55766
- OSV: https://osv.dev/vulnerability/CVE-2026-55766

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55766/
Summaries are generated and may contain mistakes; the official description above is the record.
