CVE-2026-55769 Privilege escalation in cloudnative-pg
Attackers with database owner privileges can escalate to PostgreSQL superuser and execute OS commands by exploiting unsecured search paths in CloudNativePG.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55769?
CVE-2026-55769 is a critical vulnerability in cloudnative-pg, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.28.4 and 1.29.2, CloudNativePG opened superuser connections without pinning search_path in fillDefaultParameters in pkg/management/postgres/pool/profiles.go. A role holding DATABASE OWNER could create overloaded built-in operators in the public schema and change the database or role search_path, causing instance-manager introspection queries such as SELECT COUNT(*) > 0 FROM pg_catalog.pg_extension WHERE extname = $1 to execute attacker-controlled functions as the postgres superuser. The same trust issue affected direct sql.Open("pgx", ...) callsites and the public.user_search SECURITY DEFINER function, enabling PostgreSQL superuser access, operating system command execution through COPY ... FROM PROGRAM, and access to the pod ServiceAccount token. This issue is fixed in versions 1.28.4, 1.29.2, and 1.30.0.
Weakness: CWE-426
Which versions are affected by CVE-2026-55769?
How do I fix CVE-2026-55769?
Upgrade to a fixed version.
Is CVE-2026-55769 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55769 exists.
Sources
Also known as GHSA-x8c2-3p4r-v9r6.