# CVE-2026-55769: Privilege escalation in cloudnative-pg

> Attackers with database owner privileges can escalate to PostgreSQL superuser and execute OS commands by exploiting unsecured search paths in CloudNativePG.

- **Severity:** Critical 9.4 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Aug 2026
- **Updated:** 21 Aug 2026
- **Also known as:** GHSA-x8c2-3p4r-v9r6

## What is CVE-2026-55769?

CVE-2026-55769 is a critical vulnerability in cloudnative-pg, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CloudNativePG is a platform designed to manage PostgreSQL databases within Kubernetes environments. Prior to 1.28.4 and 1.29.2, CloudNativePG opened superuser connections without pinning search_path in fillDefaultParameters in pkg/management/postgres/pool/profiles.go. A role holding DATABASE OWNER could create overloaded built-in operators in the public schema and change the database or role search_path, causing instance-manager introspection queries such as SELECT COUNT(*) > 0 FROM pg_catalog.pg_extension WHERE extname = $1 to execute attacker-controlled functions as the postgres superuser. The same trust issue affected direct sql.Open("pgx", ...) callsites and the public.user_search SECURITY DEFINER function, enabling PostgreSQL superuser access, operating system command execution through COPY ... FROM PROGRAM, and access to the pod ServiceAccount token. This issue is fixed in versions 1.28.4, 1.29.2, and 1.30.0.

Weakness: CWE-426 (Untrusted Search Path)

## Which versions are affected by CVE-2026-55769?


## How do I fix CVE-2026-55769?

Upgrade to a fixed version.

## Is CVE-2026-55769 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55769 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55769 and fix it if it is affected.

What it is: CVE-2026-55769 is a critical vulnerability in cloudnative-pg, published on 20 Aug 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55769 exists.

Affected product: cloudnative-pg. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55769/ (Markdown: https://insights.sbomify.com/CVE-2026-55769/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55769
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55769
- OSV: https://osv.dev/vulnerability/CVE-2026-55769

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55769/
Summaries are generated and may contain mistakes; the official description above is the record.
