CVE-2026-55773 CedarJava has a policy injection vulnerability
Attackers can inject arbitrary Cedar policy expressions via unescaped values, potentially bypassing authorization checks in applications using the library.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55773?
CVE-2026-55773 is a high-severity code injection vulnerability in cedar-policy cedar-java, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. In versions prior to 2.3.6, 3.4.1 and 4.9.0, under certain circumstances, improper input handling could allow Cedar-expression injection via unescaped toCedarExpr(). The toCedarExpr() method on Cedar Value types does not escape special characters (" or \) when converting values to Cedar source code. If an integrator uses toCedarExpr() to build policy text at runtime from user-controlled values, an actor could inject arbitrary Cedar expressions. For example, injecting || true into a permit ... when { ... } clause could make the permit unconditional, or injecting && false into a forbid clause could prevent the forbid from triggering. This issue requires the integrator to use toCedarExpr() to build policy text at runtime from user-controlled input. This vulnerability has been fixed in versions 2.3.6, 3.4.1, and 4.9.0.
Weakness: CWE-94
Which versions are affected by CVE-2026-55773?
6 open source packages ship an affected version, including com.cedarpolicy:cedar-java.
| Package | Affected | Fixed in |
|---|---|---|
com.cedarpolicy:cedar-java Maven | All versions | 2.3.6 |
com.cedarpolicy:cedar-java Maven | All versions | 2.3.6 |
com.cedarpolicy:cedar-java Maven | From 3.1.2 | 3.4.1 |
com.cedarpolicy:cedar-java Maven | From 3.1.2 | 3.4.1 |
com.cedarpolicy:cedar-java Maven | From 4.0.0 | 4.9.0 |
com.cedarpolicy:cedar-java Maven | From 4.0.0 | 4.9.0 |
How do I fix CVE-2026-55773?
Upgrade com.cedarpolicy:cedar-java to a fixed version for your release line: 2.3.6, 3.4.1 or 4.9.0.
Upgrade, and never evaluate templates, expressions or code built from user input. More about Code injection.
Is CVE-2026-55773 being exploited?
There is no known exploitation of CVE-2026-55773 in the wild and no public exploit code.
Sources
Also known as GHSA-qmch-v2q9-wg4p.