# CVE-2026-55773: CedarJava has a policy injection vulnerability

> Attackers can inject arbitrary Cedar policy expressions via unescaped values, potentially bypassing authorization checks in applications using the library.

- **Severity:** High 8.8 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 13 Jul 2026
- **Updated:** 15 Jul 2026
- **Also known as:** GHSA-qmch-v2q9-wg4p

## What is CVE-2026-55773?

CVE-2026-55773 is a high-severity code injection vulnerability in cedar-policy cedar-java, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

CedarJava is an open source Java implementation of the Cedar policy language, used for fine-grained authorization decisions. In versions prior to 2.3.6, 3.4.1 and 4.9.0, under certain circumstances, improper input handling could allow Cedar-expression injection via unescaped toCedarExpr(). The toCedarExpr() method on Cedar Value types does not escape special characters (" or \) when converting values to Cedar source code. If an integrator uses toCedarExpr() to build policy text at runtime from user-controlled values, an actor could inject arbitrary Cedar expressions. For example, injecting || true into a permit ... when { ... } clause could make the permit unconditional, or injecting && false into a forbid clause could prevent the forbid from triggering. This issue requires the integrator to use toCedarExpr() to build policy text at runtime from user-controlled input. This vulnerability has been fixed in versions 2.3.6, 3.4.1, and 4.9.0.

Weakness: CWE-94 (Improper Control of Generation of Code)

## Which versions are affected by CVE-2026-55773?

6 open source packages ship an affected version, including com.cedarpolicy:cedar-java.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `com.cedarpolicy:cedar-java` | Maven | All versions | 2.3.6 |
| `com.cedarpolicy:cedar-java` | Maven | All versions | 2.3.6 |
| `com.cedarpolicy:cedar-java` | Maven | From 3.1.2 | 3.4.1 |
| `com.cedarpolicy:cedar-java` | Maven | From 3.1.2 | 3.4.1 |
| `com.cedarpolicy:cedar-java` | Maven | From 4.0.0 | 4.9.0 |
| `com.cedarpolicy:cedar-java` | Maven | From 4.0.0 | 4.9.0 |

## How do I fix CVE-2026-55773?

Upgrade com.cedarpolicy:cedar-java to a fixed version for your release line: 2.3.6, 3.4.1 or 4.9.0.

## Is CVE-2026-55773 being exploited?

There is no known exploitation of CVE-2026-55773 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55773 and fix it if it is affected.

What it is: CVE-2026-55773 is a high-severity code injection vulnerability in cedar-policy cedar-java, published on 13 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55773 in the wild and no public exploit code.

Affected packages and fixed versions:
- com.cedarpolicy:cedar-java (Maven): affected all versions; fixed in 2.3.6
- com.cedarpolicy:cedar-java (Maven): affected all versions; fixed in 2.3.6
- com.cedarpolicy:cedar-java (Maven): affected from 3.1.2; fixed in 3.4.1
- com.cedarpolicy:cedar-java (Maven): affected from 3.1.2; fixed in 3.4.1
- com.cedarpolicy:cedar-java (Maven): affected from 4.0.0; fixed in 4.9.0
- com.cedarpolicy:cedar-java (Maven): affected from 4.0.0; fixed in 4.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55773/ (Markdown: https://insights.sbomify.com/CVE-2026-55773/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55773
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55773
- OSV: https://osv.dev/vulnerability/CVE-2026-55773

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55773/
Summaries are generated and may contain mistakes; the official description above is the record.
