# CVE-2026-55775: OpenBao's System Backend allows Unauthorized Management of the containing Namespace

> Attackers with specific namespace capabilities can bypass ACL checks to modify or delete the containing namespace's configuration.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:N/VI:L/VA:L/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Sep 2026
- **Updated:** 15 Sep 2026
- **Also known as:** BIT-openbao-2026-55775, GHSA-mwr2-wmgp-crj6, GO-2026-5517

## What is CVE-2026-55775?

CVE-2026-55775 is a low-severity missing authorization vulnerability in openbao, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

OpenBao is an open source identity-based secrets management system. Prior to 2.5.5, OpenBao users granted capabilities on /sys/namespaces/root within a non-root namespace could exploit special handling of the literal root path in namespace canonicalization. The /sys/namespaces/* endpoint family can resolve its containing namespace through a path prefix or X-Vault-Namespace header. ACL checks occurred before root canonicalized to an empty path, causing /sys/namespaces/root to resolve to the system backend's containing namespace and allowing permitted lookups, deletion, locking, or custom metadata changes against that direct containing namespace. The root namespace and arbitrary unrelated namespaces are not affected, and available operations depend on the capabilities granted on the path and subpaths such as /api-lock. This issue is fixed in version 2.5.5.

Weakness: CWE-285 (Improper Authorization)

## Which versions are affected by CVE-2026-55775?

6 open source packages ship an affected version, including github.com/openbao/openbao and openbao.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260617103935-d3c1cc64b1ae |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260617103935-d3c1cc64b1ae |
| `github.com/openbao/openbao` | Go | All versions | 0.0.0-20260617103935-d3c1cc64b1ae |
| `github.com/openbao/openbao` | Go | From 0.1.0 to 2.5.4 | None |
| `github.com/openbao/openbao` | Go | From 0.1.0 to 2.5.4 | None |
| `openbao` | Bitnami | All versions | 2.5.5 |

## How do I fix CVE-2026-55775?

Upgrade github.com/openbao/openbao to 0.0.0-20260617103935-d3c1cc64b1ae or later.

## Is CVE-2026-55775 being exploited?

There is no known exploitation of CVE-2026-55775 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55775 and fix it if it is affected.

What it is: CVE-2026-55775 is a low-severity missing authorization vulnerability in openbao, published on 15 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55775 in the wild and no public exploit code.

Affected packages and fixed versions:
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260617103935-d3c1cc64b1ae
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260617103935-d3c1cc64b1ae
- github.com/openbao/openbao (Go): affected all versions; fixed in 0.0.0-20260617103935-d3c1cc64b1ae
- github.com/openbao/openbao (Go): affected from 0.1.0 up to 2.5.4; no fix listed
- github.com/openbao/openbao (Go): affected from 0.1.0 up to 2.5.4; no fix listed
- openbao (Bitnami): affected all versions; fixed in 2.5.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55775/ (Markdown: https://insights.sbomify.com/CVE-2026-55775/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55775
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55775
- OSV: https://osv.dev/vulnerability/CVE-2026-55775

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55775/
Summaries are generated and may contain mistakes; the official description above is the record.
