{"answers":{"affected":"5 open source packages ship an affected version, including parse-server and parse.","exploited":"There is no known exploitation of CVE-2026-55778 in the wild and no public exploit code.","fix":"Upgrade parse-server to a fixed version for your release line: 8.6.81 or 9.9.1-alpha.11.","what":"CVE-2026-55778 is a low-severity cross-site scripting vulnerability in parse-community parse-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55778 and fix it if it is affected.\n\nWhat it is: CVE-2026-55778 is a low-severity cross-site scripting vulnerability in parse-community parse-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.\nExploitation: There is no known exploitation of CVE-2026-55778 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- parse-server (npm): affected all versions; fixed in 8.6.81\n- parse-server (npm): affected all versions; fixed in 8.6.81\n- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.11\n- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.11\n- parse (Bitnami): affected all versions; fixed in 8.6.81, 9.9.1\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55778/ (Markdown: https://insights.sbomify.com/CVE-2026-55778/index.md)","id":"CVE-2026-55778","markdown":"https://insights.sbomify.com/CVE-2026-55778/index.md","name":"CVE-2026-55778","record":{"aliases":["BIT-parse-2026-55778","GHSA-v8x7-r927-cc93"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["code_execution"],"network_reachable":"yes","non_default_config":false,"product_category":"Parse Server backend","requires_auth":"low_privilege","summary":"Attackers can upload malicious files with non-standard extensions to trigger stored XSS, potentially executing arbitrary scripts in user browsers.","user_interaction":"required","vuln_class":"xss"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":2.1,"severity":"low","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N","version":"4.0"},"cwes":[{"id":"CWE-434","name":"Unrestricted Upload of File with Dangerous Type"}],"description":"Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.11 and 8.6.81, the default fileUpload.fileExtensions blocklist could be bypassed by uploading a file with a non-standard or compound extension and dangerous content type, allowing storage adapters such as S3 and GCS to serve attacker-supplied active content and enable stored cross-site scripting. This issue is fixed in versions 9.9.1-alpha.11 and 8.6.81.","ecosystems":["Bitnami","npm"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Parse Server: Stored XSS via non-standard file extension bypassing file upload extension blocklist","id":"CVE-2026-55778","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Bitnami","product":null,"products":[],"type":"xss","year":"2026"},"n_packages":5,"n_references":7,"next":{"headline":"Silverstripe Versioned: XSS in archive admin restore","id":"CVE-2026-55779"},"packages":[{"ecosystem":"Bitnami","fixed":["8.6.81","9.9.1"],"introduced":["0","9.0.0"],"last_affected":[],"package":"parse","purl":"pkg:bitnami/parse","source":"BIT-parse-2026-55778"},{"ecosystem":"npm","fixed":["8.6.81"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-v8x7-r927-cc93"},{"ecosystem":"npm","fixed":["8.6.81"],"introduced":["0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-v8x7-r927-cc93"},{"ecosystem":"npm","fixed":["9.9.1-alpha.11"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":null,"source":"GHSA-v8x7-r927-cc93"},{"ecosystem":"npm","fixed":["9.9.1-alpha.11"],"introduced":["9.0.0"],"last_affected":[],"package":"parse-server","purl":"pkg:npm/parse-server","source":"GHSA-v8x7-r927-cc93"}],"prev":{"headline":"GoAccess: Out-of-bounds heap read in parse_ios() via crafted User-Agent leads to remote crash/DoS","id":"CVE-2026-55777"},"products":["parse-server"],"published":"2026-07-08","related":[],"sources":[{"class":"attribution","licence":"Apache-2.0","name":"Bitnami","prefix":"BIT"},{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-09","vendors":["parse-community"]},"summary":"Attackers can upload malicious files with non-standard extensions to trigger stored XSS, potentially executing arbitrary scripts in user browsers.","url":"https://insights.sbomify.com/CVE-2026-55778/"}