# CVE-2026-55778: Parse Server: Stored XSS via non-standard file extension bypassing file upload extension blocklist

> Attackers can upload malicious files with non-standard extensions to trigger stored XSS, potentially executing arbitrary scripts in user browsers.

- **Severity:** Low 2.1 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:P/VC:N/VI:L/VA:N/SC:L/SI:L/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** BIT-parse-2026-55778, GHSA-v8x7-r927-cc93

## What is CVE-2026-55778?

CVE-2026-55778 is a low-severity cross-site scripting vulnerability in parse-community parse-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Parse Server is an open source backend that can be deployed to any infrastructure that can run Node.js. Prior to 9.9.1-alpha.11 and 8.6.81, the default fileUpload.fileExtensions blocklist could be bypassed by uploading a file with a non-standard or compound extension and dangerous content type, allowing storage adapters such as S3 and GCS to serve attacker-supplied active content and enable stored cross-site scripting. This issue is fixed in versions 9.9.1-alpha.11 and 8.6.81.

Weakness: CWE-434 (Unrestricted Upload of File with Dangerous Type)

## Which versions are affected by CVE-2026-55778?

5 open source packages ship an affected version, including parse-server and parse.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `parse-server` | npm | All versions | 8.6.81 |
| `parse-server` | npm | All versions | 8.6.81 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.11 |
| `parse-server` | npm | From 9.0.0 | 9.9.1-alpha.11 |
| `parse` | Bitnami | All versions | 8.6.81, 9.9.1 |

## How do I fix CVE-2026-55778?

Upgrade parse-server to a fixed version for your release line: 8.6.81 or 9.9.1-alpha.11.

## Is CVE-2026-55778 being exploited?

There is no known exploitation of CVE-2026-55778 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55778 and fix it if it is affected.

What it is: CVE-2026-55778 is a low-severity cross-site scripting vulnerability in parse-community parse-server, published on 8 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55778 in the wild and no public exploit code.

Affected packages and fixed versions:
- parse-server (npm): affected all versions; fixed in 8.6.81
- parse-server (npm): affected all versions; fixed in 8.6.81
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.11
- parse-server (npm): affected from 9.0.0; fixed in 9.9.1-alpha.11
- parse (Bitnami): affected all versions; fixed in 8.6.81, 9.9.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55778/ (Markdown: https://insights.sbomify.com/CVE-2026-55778/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55778
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55778
- OSV: https://osv.dev/vulnerability/CVE-2026-55778

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55778/
Summaries are generated and may contain mistakes; the official description above is the record.
