# CVE-2026-55779: Silverstripe Versioned: XSS in archive admin restore

> An attacker can execute stored JavaScript in an administrator's browser by restoring an archived page with a crafted title, compromising the CMS session.

- **Severity:** Medium 5.4 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** GHSA-m4g4-86qc-v8w7

## What is CVE-2026-55779?

CVE-2026-55779 is a medium-severity cross-site scripting vulnerability in silverstripe-versioned, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Silverstripe Versioned provides versioning for Silverstripe models. Prior to 3.2.1, RestoreAction::getRestoreMessage() in src/RestoreAction.php builds ArchiveAdmin restore notifications rendered as CAST_HTML and inserts $restoredItem->Title, $restoredItem->URLSegment, $restoredItem->CMSEditLink(), and $changedProperty['value'] without applying Convert::raw2xml(). When an administrator restores an archived page containing a crafted title or URL segment, the generated restoration message can execute stored JavaScript in the administrator's browser, compromising the confidentiality and integrity of the CMS session. This issue is fixed in version 3.2.1.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55779?

2 open source packages ship an affected version, including silverstripe/versioned.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `silverstripe/versioned` | Packagist | All versions | 3.2.1 |
| `silverstripe/versioned` | Packagist | All versions | 3.2.1 |

## How do I fix CVE-2026-55779?

Upgrade silverstripe/versioned to 3.2.1 or later.

## Is CVE-2026-55779 being exploited?

There is no known exploitation of CVE-2026-55779 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55779 and fix it if it is affected.

What it is: CVE-2026-55779 is a medium-severity cross-site scripting vulnerability in silverstripe-versioned, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55779 in the wild and no public exploit code.

Affected packages and fixed versions:
- silverstripe/versioned (Packagist): affected all versions; fixed in 3.2.1
- silverstripe/versioned (Packagist): affected all versions; fixed in 3.2.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55779/ (Markdown: https://insights.sbomify.com/CVE-2026-55779/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55779
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55779
- OSV: https://osv.dev/vulnerability/CVE-2026-55779

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55779/
Summaries are generated and may contain mistakes; the official description above is the record.
