CVE-2026-55792 Craft CMS: Sensitive File Disclosure / Server-Side File Read
Craft CMS allows privileged users to read sensitive files like .env via email templates, potentially leading to admin account takeover.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55792?
CVE-2026-55792 is a medium-severity vulnerability in craftcms cms, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
Craft CMS is a content management system (CMS). In versions starting from 4.0.0-RC1 and prior to 4.18.0, and 5.0.0-RC1 and above, prior to 5.10.0, the dataUrl() Twig function is included in Craft’s Twig sandbox allowlist, allowing any control panel user granted the utility:system-messages permission to embed a file-reading payload into system email templates. When those emails are sent, the server reads the target file and returns its contents as a base64-encoded data URL embedded in the email body. The .env file, which typically contains the database password, CRAFT_SECURITY_KEY, and third-party API keys, passes all of Craft’s existing dataUrl() protection checks and is fully exfiltrated. Obtaining CRAFT_SECURITY_KEY enables an attacker to forge session tokens and escalate to full admin account takeover. This issue has been fixed in versions 4.18.0 and 5.10.0.
Weakness: CWE-200
Which versions are affected by CVE-2026-55792?
4 open source packages ship an affected version, including craftcms/cms.
| Package | Affected | Fixed in |
|---|---|---|
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.0 |
craftcms/cms Packagist | From 4.0.0-RC1 | 4.18.0 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.0 |
craftcms/cms Packagist | From 5.0.0-RC1 | 5.10.0 |
How do I fix CVE-2026-55792?
Upgrade craftcms/cms to a fixed version for your release line: 4.18.0 or 5.10.0.
Is CVE-2026-55792 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55792 exists.
Sources
Also known as GHSA-287w-mxq6-x2cp.