# CVE-2026-55792: Craft CMS: Sensitive File Disclosure / Server-Side File Read

> Craft CMS allows privileged users to read sensitive files like .env via email templates, potentially leading to admin account takeover.

- **Severity:** Medium 6.0 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 1 Jul 2026
- **Updated:** 2 Jul 2026
- **Also known as:** GHSA-287w-mxq6-x2cp

## What is CVE-2026-55792?

CVE-2026-55792 is a medium-severity vulnerability in craftcms cms, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Craft CMS is a content management system (CMS). In versions starting from 4.0.0-RC1 and prior to 4.18.0, and 5.0.0-RC1 and above, prior to 5.10.0, the dataUrl() Twig function is included in Craft’s Twig sandbox allowlist, allowing any control panel user granted the utility:system-messages permission to embed a file-reading payload into system email templates. When those emails are sent, the server reads the target file and returns its contents as a base64-encoded data URL embedded in the email body. The .env file, which typically contains the database password, CRAFT_SECURITY_KEY, and third-party API keys, passes all of Craft’s existing dataUrl() protection checks and is fully exfiltrated. Obtaining CRAFT_SECURITY_KEY enables an attacker to forge session tokens and escalate to full admin account takeover. This issue has been fixed in versions 4.18.0 and 5.10.0.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55792?

4 open source packages ship an affected version, including craftcms/cms.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.0 |
| `craftcms/cms` | Packagist | From 4.0.0-RC1 | 4.18.0 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.0 |
| `craftcms/cms` | Packagist | From 5.0.0-RC1 | 5.10.0 |

## How do I fix CVE-2026-55792?

Upgrade craftcms/cms to a fixed version for your release line: 4.18.0 or 5.10.0.

## Is CVE-2026-55792 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55792 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55792 and fix it if it is affected.

What it is: CVE-2026-55792 is a medium-severity vulnerability in craftcms cms, published on 1 Jul 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55792 exists.

Affected packages and fixed versions:
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.0
- craftcms/cms (Packagist): affected from 4.0.0-RC1; fixed in 4.18.0
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.0
- craftcms/cms (Packagist): affected from 5.0.0-RC1; fixed in 5.10.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55792/ (Markdown: https://insights.sbomify.com/CVE-2026-55792/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55792
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55792
- OSV: https://osv.dev/vulnerability/CVE-2026-55792

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55792/
Summaries are generated and may contain mistakes; the official description above is the record.
