# CVE-2026-55824: Contao crawler leaks auth credentials to external hosts

> Contao CMS leaks Basic or Bearer authentication credentials to external hosts when crawling links, exposing sensitive access tokens to attackers.

- **Severity:** Low 2.6 (`CVSS:3.1/AV:N/AC:H/PR:L/UI:R/S:U/C:L/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 31 Jul 2026
- **Updated:** 31 Jul 2026
- **Also known as:** GHSA-3mr9-p497-58f6

## What is CVE-2026-55824?

CVE-2026-55824 is a low-severity vulnerability in contao, published on 31 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Contao is an Open Source CMS. In versions 4.13.40 through 5.3.46 and 5.7.0-RC1 through 5.7.6, the crawler leaks auth credentials to external hosts. Contao's crawler tries to prevent confidential HTTP client options from being sent to external domains by creating a scoped client: full options for root page origins, cleaned options for everything else. The cleaner removes Cookie and Authorization headers, but it removes the non-Symfony option names basic_auth and bearer_auth instead of Symfony HttpClient's real auth_basic and auth_bearer options. When contao.crawl.default_http_client_options contains Basic or Bearer authentication for a protected staging/production site, those credentials remain in the "clean" client used for external links or configured additional URIs. An attacker who can get an external URL crawled, for example through a link on a crawled page while the broken-link checker is enabled, can receive the crawler credentials. This issue has been fixed in versions 5.3.47 and 5.7.7.

Weakness: CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55824?

8 open source packages ship an affected version, including contao/contao and contao/core-bundle.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `contao/contao` | Packagist | From 4.13.0 | 5.3.47 |
| `contao/contao` | Packagist | From 4.13.0 | 5.3.47 |
| `contao/contao` | Packagist | From 5.4.0 | 5.7.7 |
| `contao/contao` | Packagist | From 5.4.0 | 5.7.7 |
| `contao/core-bundle` | Packagist | From 4.13.0 | 5.3.47 |
| `contao/core-bundle` | Packagist | From 4.13.0 | 5.3.47 |
| `contao/core-bundle` | Packagist | From 5.4.0 | 5.7.7 |
| `contao/core-bundle` | Packagist | From 5.4.0 | 5.7.7 |

## How do I fix CVE-2026-55824?

Upgrade contao/contao to a fixed version for your release line: 5.3.47 or 5.7.7.

## Is CVE-2026-55824 being exploited?

There is no known exploitation of CVE-2026-55824 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55824 and fix it if it is affected.

What it is: CVE-2026-55824 is a low-severity vulnerability in contao, published on 31 Jul 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55824 in the wild and no public exploit code.

Affected packages and fixed versions:
- contao/contao (Packagist): affected from 4.13.0; fixed in 5.3.47
- contao/contao (Packagist): affected from 4.13.0; fixed in 5.3.47
- contao/contao (Packagist): affected from 5.4.0; fixed in 5.7.7
- contao/contao (Packagist): affected from 5.4.0; fixed in 5.7.7
- contao/core-bundle (Packagist): affected from 4.13.0; fixed in 5.3.47
- contao/core-bundle (Packagist): affected from 4.13.0; fixed in 5.3.47
- contao/core-bundle (Packagist): affected from 5.4.0; fixed in 5.7.7
- contao/core-bundle (Packagist): affected from 5.4.0; fixed in 5.7.7

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55824/ (Markdown: https://insights.sbomify.com/CVE-2026-55824/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55824
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55824
- OSV: https://osv.dev/vulnerability/CVE-2026-55824

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55824/
Summaries are generated and may contain mistakes; the official description above is the record.
