# CVE-2026-55833: Netty SPDY zlib header block continues decoded expansion after maxHeaderSize truncation

> Remote attackers can cause CPU and memory exhaustion in Netty SPDY servers by sending compressed headers that expand beyond size limits.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 20 Jul 2026
- **Updated:** 21 Jul 2026
- **Also known as:** CLEANSTART-2026-GK74613, CLEANSTART-2026-GN07602, CLEANSTART-2026-MW15719, CLEANSTART-2026-RF04953, CLEANSTART-2026-RR19922, DEBIAN-CVE-2026-55833, ECHO-7222-b3d2-8bac, GHSA-mvh2-crg5-v77c, MINI-22f9-75wp-3wq7, MINI-23j5-g8gc-cmx6, MINI-26jw-4vgx-p8h8, MINI-2hqj-pfrc-4p84, MINI-2m96-487m-j7hx, MINI-2wgx-wc69-q47g, MINI-2xwg-pq9x-hwj6, MINI-3h9v-qfcq-6f3m, MINI-3mrf-cj2w-jcj7, MINI-4435-h25q-pg4q, MINI-44f2-7qpw-w5qw, MINI-46g7-6pfg-457p, MINI-47qj-68v2-5jrp, MINI-48h7-q7xx-fwcm, MINI-4c28-pm55-f938, MINI-4f36-vc26-hhvm, MINI-4j79-37pv-pm65, MINI-4wmr-7g6q-jpfr, MINI-54vj-7qvc-7hg2, MINI-56g7-4gx5-8374, MINI-56hv-jvf6-v8v5, MINI-5chm-pm2r-c4rj, MINI-5pwr-rm8w-8wqp, MINI-5w5h-qxgf-xp7r, MINI-62gc-c934-2mw8, MINI-63p4-w968-785p, MINI-64f7-qv24-v755, MINI-65v6-pw4g-chqx, MINI-6ph3-w6h9-w5gh, MINI-6x7g-3v85-xjwq, MINI-73q4-xv8f-5x8p, MINI-77qv-xx4r-q6h4, MINI-7c39-54qx-hc6h, MINI-7cfq-p4x9-83v3, MINI-7j47-q796-3hh8, MINI-7qhm-38xq-hq92, MINI-8387-3vxv-97hx, MINI-85r4-9925-x45w, MINI-87r4-hfrw-fcfj, MINI-88hm-89gj-3929, MINI-8jcp-244f-7rc3, MINI-8jxq-mhmx-m47r, MINI-9h48-v365-3gx8, MINI-c89w-p497-jmxv, MINI-c8mf-grfx-c78x, MINI-cw6h-qg8r-r66c, MINI-f4gh-3599-x6qc, MINI-fh2f-j7v3-wwmc, MINI-g4cr-m5jv-j8mf, MINI-g73c-cfxh-mcj4, MINI-gw5m-qm6m-59rh, MINI-gx33-577h-6hxc, MINI-h5x6-wqrr-m33f, MINI-h67p-x64p-qjm5, MINI-hffj-92g2-jvg5, MINI-hgg3-gj5g-6xmm, MINI-hx64-6j82-9x9h, MINI-hxjg-fcfc-q92c, MINI-j248-wwq4-6fxp, MINI-j63q-58g3-4vw4, MINI-j73r-c56p-hg6j, MINI-j84j-jwjp-76rc, MINI-jfj9-g6jj-q79c, MINI-jhhv-84cq-w3j3, MINI-jj56-7hrq-ww5v, MINI-jj5g-532m-9h8x, MINI-jq9f-p665-7pm2, MINI-m2gr-53vx-v22m, MINI-p56v-h2gh-7h28, MINI-pcrp-fmq4-wcc4, MINI-pf92-3hgq-7g54, MINI-q35j-c57v-8w46, MINI-q6mw-vg6j-752w, MINI-q75j-2gqf-g9cr, MINI-qc42-jcgx-hxwc, MINI-qf4p-54rp-vv69, MINI-qj8f-78fq-76xg, MINI-qpqh-39pm-c5g4, MINI-qq8p-2hmh-9hpq, MINI-qw9v-x2q9-9r85, MINI-r8cg-gqv4-xpvq, MINI-rcfx-x9g6-f5gw, MINI-rghc-7g6r-7jw4, MINI-v76h-79j6-pq3j, MINI-v7qg-xq76-vm27, MINI-vgjf-6r94-c8gc, MINI-vpj2-335r-r285, MINI-vqx8-56gr-h7x4, MINI-w2c3-cr9w-x4mf, MINI-w55x-xm5w-9hwj, MINI-w7fq-c934-829q, MINI-wfhp-6gmv-2cvm, MINI-wj2w-3hm9-r49x, MINI-wjx7-xj4r-9hmq, MINI-wqjh-pxfj-qf5x, MINI-wv4v-3gjm-6cq2, MINI-x3fj-59pj-wpch, MINI-x64f-82q2-p68v, MINI-x747-xpw7-7rh6, MINI-x75r-xfcm-27rm, MINI-x7m5-hjx8-qh4f, MINI-xc3w-23rm-8j89, MINI-xprp-pqwx-4xcc, MINI-xvmr-xx54-fj42, MINI-xxg4-82pp-4jwq, ROOT-APP-MAVEN-CVE-2026-55833, UBUNTU-CVE-2026-55833

## What is CVE-2026-55833?

CVE-2026-55833 is a high-severity denial of service vulnerability in Netty Netty, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Netty is a network application framework for development of protocol servers and clients. Prior to 4.1.136.Final and 4.2.16.Final, Netty SPDY header decoding continues inflating zlib-compressed header blocks after the raw header parser has exceeded `maxHeaderSize` and marked the frame truncated in `SpdyFrameCodec`, allowing a remote peer to send a small compressed `HEADERS` block that expands into much larger raw header data and causes compression-amplified CPU and allocation churn. This issue is fixed in versions 4.1.136.Final and 4.2.16.Final.

Weakness: CWE-400 (Uncontrolled Resource Consumption)

## Which versions are affected by CVE-2026-55833?

4 open source packages ship an affected version, including io.netty:netty-codec-http. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.netty:netty-codec-http` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | From 4.1.0.Final | 4.1.136.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |
| `io.netty:netty-codec-http` | Maven | From 4.2.0.Final | 4.2.16.Final |

Products: Netty Netty.

## How do I fix CVE-2026-55833?

Upgrade io.netty:netty-codec-http to a fixed version for your release line: 4.1.136.Final or 4.2.16.Final.

## Is CVE-2026-55833 being exploited?

There is no known exploitation of CVE-2026-55833 in the wild and no public exploit code.

## Other vulnerabilities in Netty Netty

- [CVE-2026-75595](https://insights.sbomify.com/CVE-2026-75595/): Netty: SNI Routing Bypass via Fragmented TLS ClientHello Causing Fallback to Default SslContext (critical 9.1)
- [CVE-2026-75596](https://insights.sbomify.com/CVE-2026-75596/): Netty: Fragmented ClientHello records trigger quadratic pre-handshake reassembly in default SNI parsing (high 8.7)
- [CVE-2026-59901](https://insights.sbomify.com/CVE-2026-59901/): Netty Bzip2Decoder: Infinite Loop in RLE State Machine Leads to Event-Loop Thread Hang (high 8.7)
- [CVE-2026-55851](https://insights.sbomify.com/CVE-2026-55851/): Netty codec-haproxy: Signed-Byte Sentinel Collision in HAProxyMessageDecoder Leads to Unbounded Memory Exhaustion (high 8.7)
- [CVE-2026-56745](https://insights.sbomify.com/CVE-2026-56745/): Netty SpdyHttpDecoder: ByteBuf Reference Leak on RST_STREAM Leads to Native Memory Exhaustion (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55833 and fix it if it is affected.

What it is: CVE-2026-55833 is a high-severity denial of service vulnerability in Netty Netty, published on 20 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55833 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.netty:netty-codec-http (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected from 4.1.0.Final; fixed in 4.1.136.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final
- io.netty:netty-codec-http (Maven): affected from 4.2.0.Final; fixed in 4.2.16.Final

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55833/ (Markdown: https://insights.sbomify.com/CVE-2026-55833/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55833
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55833
- OSV: https://osv.dev/vulnerability/CVE-2026-55833

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55833/
Summaries are generated and may contain mistakes; the official description above is the record.
