{"answers":{"affected":"3 open source packages ship an affected version, including github.com/pocket-id/pocket-id/backend.","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55834 exists.","fix":"Upgrade github.com/pocket-id/pocket-id/backend to 2.9.0 or later.","what":"CVE-2026-55834 is a medium-severity vulnerability in pocket-id, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link."},"fix_prompt":"Check this codebase for CVE-2026-55834 and fix it if it is affected.\n\nWhat it is: CVE-2026-55834 is a medium-severity vulnerability in pocket-id, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55834 exists.\n\nAffected packages and fixed versions:\n- github.com/pocket-id/pocket-id/backend (Go): affected all versions; no fix listed\n- github.com/pocket-id/pocket-id/backend (Go): affected from 2.6.0; fixed in 2.9.0\n- github.com/pocket-id/pocket-id/backend (Go): affected from 2.6.0; fixed in 2.9.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55834/ (Markdown: https://insights.sbomify.com/CVE-2026-55834/index.md)","id":"CVE-2026-55834","markdown":"https://insights.sbomify.com/CVE-2026-55834/index.md","name":"CVE-2026-55834","record":{"aliases":["GHSA-2wvm-8mvp-22qv","GO-2026-6305"],"analysis":{"component_type":"server_software","fix_type":"upgrade","impacts":["security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"OIDC identity provider","requires_auth":"none","summary":"An attacker can redirect victims to malicious sites via unvalidated redirect_uri in Pocket ID's OIDC authorize flow, enabling phishing or state smuggling.","user_interaction":"required","vuln_class":"open_redirect"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":4.3,"severity":"medium","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N","version":"3.1"},"cwes":[{"id":"CWE-601","name":"URL Redirection to Untrusted Site"}],"description":"Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to services. From 2.6.0 until 2.9.0, frontend/src/routes/authorize/+page.ts reads the redirect_uri query parameter and frontend/src/routes/authorize/+page.svelte uses the raw callbackURL in redirectWithError when prompt=none cannot complete silent authorization. The client-side path only blocks javascript and data schemes and does not invoke the backend callback allow-list validation, so an unauthenticated attacker who knows a valid client_id can redirect a victim browser to an arbitrary HTTP or HTTPS origin for phishing or OIDC error and state smuggling. This issue is fixed in version 2.9.0.","ecosystems":["Go"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":true,"headline":"Pocket ID: Open Redirect on the OIDC /authorize page via unvalidated redirect_uri with prompt=none","id":"CVE-2026-55834","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Go","product":null,"products":[],"type":"open_redirect","year":"2026"},"n_packages":3,"n_references":3,"next":{"headline":"Lookyloo: Potential sub-system DoS due to parameter missmatch in notification","id":"CVE-2026-55835"},"packages":[{"ecosystem":"Go","fixed":[],"introduced":["0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":"pkg:golang/github.com/pocket-id/pocket-id/backend","source":"GO-2026-6305"},{"ecosystem":"Go","fixed":["2.9.0"],"introduced":["2.6.0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":null,"source":"GHSA-2wvm-8mvp-22qv"},{"ecosystem":"Go","fixed":["2.9.0"],"introduced":["2.6.0"],"last_affected":[],"package":"github.com/pocket-id/pocket-id/backend","purl":"pkg:golang/github.com/pocket-id/pocket-id/backend","source":"GHSA-2wvm-8mvp-22qv"}],"prev":{"headline":"Netty SPDY zlib header block continues decoded expansion after maxHeaderSize truncation","id":"CVE-2026-55833"},"products":["pocket-id"],"published":"2026-08-28","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"CC BY 4.0","name":"Go Vulnerability Database","prefix":"GO"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-08-28","vendors":["pocket-id"]},"summary":"An attacker can redirect victims to malicious sites via unvalidated redirect_uri in Pocket ID's OIDC authorize flow, enabling phishing or state smuggling.","url":"https://insights.sbomify.com/CVE-2026-55834/"}