# CVE-2026-55834: Pocket ID: Open Redirect on the OIDC /authorize page via unvalidated redirect_uri with prompt=none

> An attacker can redirect victims to malicious sites via unvalidated redirect_uri in Pocket ID's OIDC authorize flow, enabling phishing or state smuggling.

- **Severity:** Medium 4.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 28 Aug 2026
- **Also known as:** GHSA-2wvm-8mvp-22qv, GO-2026-6305

## What is CVE-2026-55834?

CVE-2026-55834 is a medium-severity vulnerability in pocket-id, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Pocket ID is an OIDC provider that allows users to authenticate with their passkeys to services. From 2.6.0 until 2.9.0, frontend/src/routes/authorize/+page.ts reads the redirect_uri query parameter and frontend/src/routes/authorize/+page.svelte uses the raw callbackURL in redirectWithError when prompt=none cannot complete silent authorization. The client-side path only blocks javascript and data schemes and does not invoke the backend callback allow-list validation, so an unauthenticated attacker who knows a valid client_id can redirect a victim browser to an arbitrary HTTP or HTTPS origin for phishing or OIDC error and state smuggling. This issue is fixed in version 2.9.0.

Weakness: CWE-601 (URL Redirection to Untrusted Site)

## Which versions are affected by CVE-2026-55834?

3 open source packages ship an affected version, including github.com/pocket-id/pocket-id/backend.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `github.com/pocket-id/pocket-id/backend` | Go | All versions | None |
| `github.com/pocket-id/pocket-id/backend` | Go | From 2.6.0 | 2.9.0 |
| `github.com/pocket-id/pocket-id/backend` | Go | From 2.6.0 | 2.9.0 |

## How do I fix CVE-2026-55834?

Upgrade github.com/pocket-id/pocket-id/backend to 2.9.0 or later.

## Is CVE-2026-55834 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55834 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55834 and fix it if it is affected.

What it is: CVE-2026-55834 is a medium-severity vulnerability in pocket-id, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55834 exists.

Affected packages and fixed versions:
- github.com/pocket-id/pocket-id/backend (Go): affected all versions; no fix listed
- github.com/pocket-id/pocket-id/backend (Go): affected from 2.6.0; fixed in 2.9.0
- github.com/pocket-id/pocket-id/backend (Go): affected from 2.6.0; fixed in 2.9.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55834/ (Markdown: https://insights.sbomify.com/CVE-2026-55834/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55834
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55834
- OSV: https://osv.dev/vulnerability/CVE-2026-55834

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55834/
Summaries are generated and may contain mistakes; the official description above is the record.
