# CVE-2026-55839: Kestra: Stored XSS via custom Markdown [[link]] attribute injection

> An attacker with flow creation permissions can inject JavaScript via custom Markdown links, leading to stored XSS against other users.

- **Severity:** High 8.7 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:C/C:H/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Aug 2026
- **Updated:** 18 Aug 2026
- **Also known as:** GHSA-34pm-923j-7wf8

## What is CVE-2026-55839?

CVE-2026-55839 is a high-severity cross-site scripting vulnerability in kestra-io kestra, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Kestra is an open-source, event-driven orchestration platform. Prior to 1.3.24, Kestra's custom Markdown parser in ui/src/utils/markdown_plugins/link.ts allows a user with permission to create or update a Flow description to inject JavaScript event-handler attributes through the custom [[link]] syntax, causing stored cross-site scripting when another user opens the description or information panel in the Flow list. This issue is fixed in version 1.3.24.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55839?

2 open source packages ship an affected version, including io.kestra:kestra.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `io.kestra:kestra` | Maven | All versions | 1.3.24 |
| `io.kestra:kestra` | Maven | All versions | 1.3.24 |

## How do I fix CVE-2026-55839?

Upgrade io.kestra:kestra to 1.3.24 or later.

## Is CVE-2026-55839 being exploited?

There is no known exploitation of CVE-2026-55839 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55839 and fix it if it is affected.

What it is: CVE-2026-55839 is a high-severity cross-site scripting vulnerability in kestra-io kestra, published on 18 Aug 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55839 in the wild and no public exploit code.

Affected packages and fixed versions:
- io.kestra:kestra (Maven): affected all versions; fixed in 1.3.24
- io.kestra:kestra (Maven): affected all versions; fixed in 1.3.24

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55839/ (Markdown: https://insights.sbomify.com/CVE-2026-55839/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55839
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55839
- OSV: https://osv.dev/vulnerability/CVE-2026-55839

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55839/
Summaries are generated and may contain mistakes; the official description above is the record.
