# CVE-2026-55841: Graylog: Fortigate syslog message parser can be exploited to modify or delete fields from the original message

> An unauthenticated attacker can manipulate or delete security log fields via crafted syslog messages, potentially evading detection in Graylog.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 1 Sep 2026
- **Also known as:** GHSA-gqr6-r77p-c2pj

## What is CVE-2026-55841?

CVE-2026-55841 is a high-severity vulnerability in graylog2-server, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Graylog is a free and open log management platform. Prior to Graylog Server versions 6.3.12, 7.0.7, and 7.1.2 and Graylog Forwarder version 7.3, the FortiGate key-value syslog parser in graylog2-server/src/main/java/org/graylog2/inputs/codecs/GLFortiGateSyslogEvent.java and graylog2-server/src/main/java/org/graylog2/inputs/codecs/SyslogCodec.java mishandles field-like text inside quoted values. GLFortiGateSyslogEvent.getFields() uses KV_PATTERN and QUOTED_KV_PATTERN, while SyslogCodec.parse() invokes the FortiGateSyslogEvent parser; crafted values containing = or backslash-escaped quotes can cause embedded keys such as srcip, dstip, date, time, and tz to remove or overwrite original top-level fields or produce an invalid message that Graylog discards. An unauthenticated network sender who can submit syslog messages can therefore manipulate security-log fields or evade logging to obscure malicious activity. This issue is fixed in Graylog Server versions 6.3.12, 7.0.7, and 7.1.2 and Graylog Forwarder version 7.3.

Weakness: CWE-138 (Improper Neutralization of Special Elements)

## Which versions are affected by CVE-2026-55841?

6 open source packages ship an affected version, including org.graylog2:graylog2-server.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.graylog2:graylog2-server` | Maven | All versions | 6.3.12 |
| `org.graylog2:graylog2-server` | Maven | All versions | 6.3.12 |
| `org.graylog2:graylog2-server` | Maven | From 7.0.0 | 7.0.7 |
| `org.graylog2:graylog2-server` | Maven | From 7.0.0 | 7.0.7 |
| `org.graylog2:graylog2-server` | Maven | From 7.1.0 | 7.1.2 |
| `org.graylog2:graylog2-server` | Maven | From 7.1.0 | 7.1.2 |

## How do I fix CVE-2026-55841?

Upgrade org.graylog2:graylog2-server to a fixed version for your release line: 6.3.12, 7.0.7 or 7.1.2.

## Is CVE-2026-55841 being exploited?

There is no known exploitation of CVE-2026-55841 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55841 and fix it if it is affected.

What it is: CVE-2026-55841 is a high-severity vulnerability in graylog2-server, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55841 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 6.3.12
- org.graylog2:graylog2-server (Maven): affected all versions; fixed in 6.3.12
- org.graylog2:graylog2-server (Maven): affected from 7.0.0; fixed in 7.0.7
- org.graylog2:graylog2-server (Maven): affected from 7.0.0; fixed in 7.0.7
- org.graylog2:graylog2-server (Maven): affected from 7.1.0; fixed in 7.1.2
- org.graylog2:graylog2-server (Maven): affected from 7.1.0; fixed in 7.1.2

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55841/ (Markdown: https://insights.sbomify.com/CVE-2026-55841/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55841
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55841
- OSV: https://osv.dev/vulnerability/CVE-2026-55841

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55841/
Summaries are generated and may contain mistakes; the official description above is the record.
