{"answers":{"affected":"2 open source packages ship an affected version, including snipe/snipe-it. It affects 1 product.","exploited":"There is no known exploitation of CVE-2026-55843 in the wild and no public exploit code.","fix":"Upgrade snipe/snipe-it to 8.6.0 or later.","what":"CVE-2026-55843 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55843 and fix it if it is affected.\n\nWhat it is: CVE-2026-55843 is a high-severity vulnerability in Snipeitapp Snipe-It, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-55843 in the wild and no public exploit code.\n\nAffected packages and fixed versions:\n- snipe/snipe-it (Packagist): affected all versions; fixed in 8.6.0\n- snipe/snipe-it (Packagist): affected all versions; fixed in 8.6.0\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55843/ (Markdown: https://insights.sbomify.com/CVE-2026-55843/index.md)","id":"CVE-2026-55843","markdown":"https://insights.sbomify.com/CVE-2026-55843/index.md","name":"CVE-2026-55843","record":{"aliases":["GHSA-j5g3-42wp-gqm3"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["privilege_escalation","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"IT asset management","requires_auth":"high_privilege","summary":"Attackers can overwrite target user permissions during updates, potentially removing administrative rights or escalating privileges in Snipe-IT.","user_interaction":"not_required","vuln_class":"privilege_escalation"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[{"product":"snipe-it","vendor":"snipeitapp"}],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:N/AC:L/AT:N/PR:H/UI:N/VC:N/VI:H/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-269","name":"Improper Privilege Management"}],"description":"Snipe-IT is an IT asset/license management system. Prior to 8.6.0, UsersController::update() passes a missing permission request field through NormalizePermissionsPayloadAction and PreserveUnauthorizedPrivilegedPermissionsAction in a way that can overwrite a target user’s permissions with a sparse result, allowing an administrator updating another administrator, or a user with users.edit updating a regular account, to remove the target’s administrative or granular permissions. This issue is fixed in version 8.6.0.","ecosystems":["Packagist"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"Snipe-IT: Improper Privilege Management","id":"CVE-2026-55843","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":"Packagist","product":"snipeitapp:snipe-it","products":["snipeitapp:snipe-it"],"type":"privilege_escalation","year":"2026"},"n_packages":2,"n_references":3,"next":{"headline":"Information disclosure in core","id":"CVE-2026-55844"},"packages":[{"ecosystem":"Packagist","fixed":["8.6.0"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":null,"source":"GHSA-j5g3-42wp-gqm3"},{"ecosystem":"Packagist","fixed":["8.6.0"],"introduced":["0"],"last_affected":[],"package":"snipe/snipe-it","purl":"pkg:composer/snipe/snipe-it","source":"GHSA-j5g3-42wp-gqm3"}],"prev":{"headline":"Scoold: CORS wildcard origin with credentials enabled allows cross-origin authenticated API access from any domain","id":"CVE-2026-55842"},"products":["snipe-it"],"published":"2026-07-10","related":[{"cvss_score":9.9,"headline":"File upload in n/a","id":"CVE-2025-63601","kev_date_added":null,"published":"2025-11-05"},{"cvss_score":9.8,"headline":"Snipe-IT has insecure permissions in file uploads","id":"CVE-2026-37709","kev_date_added":null,"published":"2026-05-07"},{"cvss_score":9.3,"headline":"Snipe-IT before 8.7.0 CSS Injection via Custom CSS","id":"CVE-2026-86738","kev_date_added":null,"published":"2026-09-08"},{"cvss_score":9.2,"headline":"Snipe-IT before 8.6.3 Authentication Bypass via Google SSO Callback","id":"CVE-2026-116199","kev_date_added":null,"published":"2026-10-25"},{"cvss_score":9.1,"headline":"Stored Cross Site Scripting vulnerability in Item name parameter in snipe/snipe-it","id":"CVE-2022-1380","kev_date_added":null,"published":"2022-04-16"},{"cvss_score":9,"headline":"Stored Cross Site Scripting vulnerability in the checked_out_to parameter in snipe/snipe-it","id":"CVE-2022-1445","kev_date_added":null,"published":"2022-04-24"},{"cvss_score":8.8,"headline":"Snipe-IT - Host Header Injection","id":"CVE-2022-23064","kev_date_added":null,"published":"2022-05-02"}],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"GitHub Advisory Database","prefix":"GHSA"},{"class":"attribution","licence":"US public information, NVD API terms","name":"NVD"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-07-13","vendors":["grokability"]},"summary":"Attackers can overwrite target user permissions during updates, potentially removing administrative rights or escalating privileges in Snipe-IT.","url":"https://insights.sbomify.com/CVE-2026-55843/"}