# CVE-2026-55849: @cyclonedx/cyclonedx-npm: Shell Injection via Unsanitized `--workspace` Argument

> Attackers can execute arbitrary OS commands via unsanitized workspace arguments in the CycloneDX npm CLI when specific environment variables are unset.

- **Severity:** High 8.5 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-v75r-vx73-82pj

## What is CVE-2026-55849?

CVE-2026-55849 is a high-severity command injection vulnerability in cyclonedx-node-npm, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

@cyclonedx/cyclonedx-npm creates CycloneDX Software Bill of Materials from npm projects. From 2.1.0 before 5.0.0, the CLI passes user-supplied --workspace values to a subshell without proper sanitization when npm_execpath is unset or empty, allowing arbitrary OS command execution with the privileges of the invoking user. This issue is fixed in version 5.0.0.

Weakness: CWE-78 (Improper Neutralization of Special Elements used in an OS Command)

## Which versions are affected by CVE-2026-55849?

2 open source packages ship an affected version, including @cyclonedx/cyclonedx-npm.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@cyclonedx/cyclonedx-npm` | npm | From 2.1.0 | 5.0.0 |
| `@cyclonedx/cyclonedx-npm` | npm | From 2.1.0 | 5.0.0 |

## How do I fix CVE-2026-55849?

Upgrade @cyclonedx/cyclonedx-npm to 5.0.0 or later.

## Is CVE-2026-55849 being exploited?

There is no known exploitation of CVE-2026-55849 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55849 and fix it if it is affected.

What it is: CVE-2026-55849 is a high-severity command injection vulnerability in cyclonedx-node-npm, published on 8 Jul 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55849 in the wild and no public exploit code.

Affected packages and fixed versions:
- @cyclonedx/cyclonedx-npm (npm): affected from 2.1.0; fixed in 5.0.0
- @cyclonedx/cyclonedx-npm (npm): affected from 2.1.0; fixed in 5.0.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55849/ (Markdown: https://insights.sbomify.com/CVE-2026-55849/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55849
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55849
- OSV: https://osv.dev/vulnerability/CVE-2026-55849

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55849/
Summaries are generated and may contain mistakes; the official description above is the record.
