CVE-2026-55854 MariaDB has Cleartext Transmission of Sensitive Information and Insufficiently Protected Credentials
An attacker can intercept cleartext passwords during PAM authentication if TLS is disabled, exposing sensitive credentials to on-path adversaries.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55854?
CVE-2026-55854 is a medium-severity vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js can disclose an account password when PAM dialog authentication is negotiated over an insecure transport. In lib/cmd/handshake/auth/pam-password-auth.js and lib/cmd/handshake/authentication.js, the SendPamAuthPacketFactory behavior for the server-side plugin dialog lacked the secure-transport gate applied to mysql_clear_password. With the default sslMode=DISABLE and restrictedAuth=null settings, a hostile or on-path server can send an Authentication Switch Request for dialog over plain TCP, causing the connector to return the account password in cleartext. Properly verified TLS and a local Unix socket prevent this path, while fingerprint-only server identity validation is not sufficient. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.
Which versions are affected by CVE-2026-55854?
11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | From 3.3.0 | 3.3.3 |
mariadb npm | From 3.3.0 | 3.3.3 |
mariadb npm | From 3.4.0 | 3.4.6 |
5 more packages
mariadb npm | From 3.4.0 | 3.4.6 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb-min Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
mysql-client Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
How do I fix CVE-2026-55854?
Upgrade mariadb to a fixed version for your release line: 3.2.4, 3.3.3, 3.4.6 or 3.5.3.
Is CVE-2026-55854 being exploited?
There is no known exploitation of CVE-2026-55854 in the wild and no public exploit code.
Sources
Also known as BIT-mariadb-2026-55854, BIT-mariadb-min-2026-55854, BIT-mysql-client-2026-55854, GHSA-42r5-vhpq-m858.