# CVE-2026-55854: MariaDB has Cleartext Transmission of Sensitive Information and Insufficiently Protected Credentials

> An attacker can intercept cleartext passwords during PAM authentication if TLS is disabled, exposing sensitive credentials to on-path adversaries.

- **Severity:** Medium 5.9 (`CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 28 Aug 2026
- **Updated:** 31 Aug 2026
- **Also known as:** BIT-mariadb-2026-55854, BIT-mariadb-min-2026-55854, BIT-mysql-client-2026-55854, GHSA-42r5-vhpq-m858

## What is CVE-2026-55854?

CVE-2026-55854 is a medium-severity vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js can disclose an account password when PAM dialog authentication is negotiated over an insecure transport. In lib/cmd/handshake/auth/pam-password-auth.js and lib/cmd/handshake/authentication.js, the SendPamAuthPacketFactory behavior for the server-side plugin dialog lacked the secure-transport gate applied to mysql_clear_password. With the default sslMode=DISABLE and restrictedAuth=null settings, a hostile or on-path server can send an Authentication Switch Request for dialog over plain TCP, causing the connector to return the account password in cleartext. Properly verified TLS and a local Unix socket prevent this path, while fingerprint-only server identity validation is not sufficient. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-319 (Cleartext Transmission of Sensitive Information)

## Which versions are affected by CVE-2026-55854?

11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `mariadb` | Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
| `mariadb` | npm | All versions | 3.2.4 |
| `mariadb` | npm | All versions | 3.2.4 |
| `mariadb` | npm | From 3.3.0 | 3.3.3 |
| `mariadb` | npm | From 3.3.0 | 3.3.3 |
| `mariadb` | npm | From 3.4.0 | 3.4.6 |
| `mariadb` | npm | From 3.4.0 | 3.4.6 |
| `mariadb` | npm | From 3.5.0 | 3.5.3 |
| `mariadb` | npm | From 3.5.0 | 3.5.3 |
| `mariadb-min` | Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
| `mysql-client` | Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |

## How do I fix CVE-2026-55854?

Upgrade mariadb to a fixed version for your release line: 3.2.4, 3.3.3, 3.4.6 or 3.5.3.

## Is CVE-2026-55854 being exploited?

There is no known exploitation of CVE-2026-55854 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55854 and fix it if it is affected.

What it is: CVE-2026-55854 is a medium-severity vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55854 in the wild and no public exploit code.

Affected packages and fixed versions:
- mariadb (Bitnami): affected all versions; fixed in 3.2.4, 3.3.3, 3.4.6, 3.5.3
- mariadb (npm): affected all versions; fixed in 3.2.4
- mariadb (npm): affected all versions; fixed in 3.2.4
- mariadb (npm): affected from 3.3.0; fixed in 3.3.3
- mariadb (npm): affected from 3.3.0; fixed in 3.3.3
- mariadb (npm): affected from 3.4.0; fixed in 3.4.6
- mariadb (npm): affected from 3.4.0; fixed in 3.4.6
- mariadb (npm): affected from 3.5.0; fixed in 3.5.3
- mariadb (npm): affected from 3.5.0; fixed in 3.5.3
- mariadb-min (Bitnami): affected all versions; fixed in 3.2.4, 3.3.3, 3.4.6, 3.5.3
- mysql-client (Bitnami): affected all versions; fixed in 3.2.4, 3.3.3, 3.4.6, 3.5.3

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55854/ (Markdown: https://insights.sbomify.com/CVE-2026-55854/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55854
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55854
- OSV: https://osv.dev/vulnerability/CVE-2026-55854

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55854/
Summaries are generated and may contain mistakes; the official description above is the record.
