CVE-2026-55855 MariaDB has possible SQL injection in Buffer parameter escaping under big5/gbk/sjis/cp932/gb18030 client charsets
SQL injection via Buffer parameters in MariaDB Node.js connector when using specific multibyte character sets, allowing data exposure or modification.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55855?
CVE-2026-55855 is a medium-severity SQL injection vulnerability in mariadb-corporation mariadb-connector-nodejs, published on 28 Aug 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
MariaDB Connector/Node.js is used to connect applications developed on Node.js to MariaDB and MySQL databases. Prior to 3.2.4, 3.3.3, 3.4.6, and 3.5.3, MariaDB Connector/Node.js permits SQL injection when attacker-controlled Buffer parameters are escaped client-side under the big5, gbk, sjis, cp932, or gb18030 client character sets. PacketOutputStream.writeBufferEscape in lib/io/packet-output-stream.js escaped bytes without the charset-aware getMbRecognizer logic in lib/misc/charset-mb.js. The server SQL lexer runs my_ismbchar before escape processing, so an attacker-controlled lead byte can consume the inserted 0x5C backslash as a multibyte trail byte and leave the following 0x27 quote unescaped, terminating the string literal and allowing arbitrary SQL. The default utf8mb4 character set and parameters sent through the execute binary prepared-statement path are not affected. Successful exploitation can expose or modify data available to the database account. This issue is fixed in versions 3.2.4, 3.3.3, 3.4.6, and 3.5.3.
Which versions are affected by CVE-2026-55855?
11 open source packages ship an affected version, including mariadb, mariadb-min and mysql-client.
| Package | Affected | Fixed in |
|---|---|---|
mariadb Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | All versions | 3.2.4 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.3.0 | 3.3.4 |
mariadb npm | From 3.4.0 | 3.4.6 |
5 more packages
mariadb npm | From 3.4.0 | 3.4.6 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb npm | From 3.5.0 | 3.5.3 |
mariadb-min Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
mysql-client Bitnami | All versions | 3.2.4, 3.3.3, 3.4.6, 3.5.3 |
How do I fix CVE-2026-55855?
Upgrade mariadb to a fixed version for your release line: 3.2.4, 3.3.3, 3.4.6 or 3.5.3.
Use parameterised queries everywhere and never build SQL by joining strings. Upgrade affected software first; a web application firewall only buys time. More about SQL injection.
Is CVE-2026-55855 being exploited?
There is no known exploitation of CVE-2026-55855 in the wild and no public exploit code.
Sources
Also known as BIT-mariadb-2026-55855, BIT-mariadb-min-2026-55855, BIT-mysql-client-2026-55855, GHSA-g5xc-5w98-jfvm.