# CVE-2026-55870: GoCD is vulnerable to credential exposure when admins insecurely configure material URLs

> Authenticated users can read unmasked credentials from insecurely configured source control material URLs in GoCD.

- **Severity:** Low 2.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:L/UI:N/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 21 Sep 2026
- **Updated:** 21 Sep 2026
- **Also known as:** GHSA-5m25-5j77-c887

## What is CVE-2026-55870?

CVE-2026-55870 is a low-severity vulnerability in gocd, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

GoCD is a continuous deliver server. Prior to 26.1.0, GoCD can return unmasked credentials that administrators stored in the userinfo portion of source control material URLs through several read-only APIs available to regular authenticated users. Although GoCD recommends dedicated username and password fields or secret-management plugins, legacy configuration permits credentials in material URLs, and not every mixed-use API consistently applies URL masking for every material type. An authenticated user with access to an affected pipeline can obtain credentials embedded in its material URL, while dedicated password fields remain encrypted and are not exposed by this issue. This issue is fixed in version 26.1.0.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor)

## Which versions are affected by CVE-2026-55870?


## How do I fix CVE-2026-55870?

No fix has been published for CVE-2026-55870 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55870 being exploited?

There is no known exploitation of CVE-2026-55870 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55870 and fix it if it is affected.

What it is: CVE-2026-55870 is a low-severity vulnerability in gocd, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55870 in the wild and no public exploit code.

Affected product: gocd. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55870/ (Markdown: https://insights.sbomify.com/CVE-2026-55870/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55870
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55870
- OSV: https://osv.dev/vulnerability/CVE-2026-55870

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55870/
Summaries are generated and may contain mistakes; the official description above is the record.
