# CVE-2026-55876: Helium: Stored XSS via Unrestricted SVG File Upload — Authenticated Users Can Store Executable Scripts

> Authenticated users can upload malicious SVG files to execute scripts in victim browsers, enabling phishing and content manipulation.

- **Severity:** Low 3.5 (`CVSS:3.1/AV:N/AC:L/PR:L/UI:R/S:U/C:N/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 15 Oct 2026
- **Updated:** 21 Oct 2026
- **Also known as:** GHSA-7r65-76fw-ch5c

## What is CVE-2026-55876?

CVE-2026-55876 is a low-severity cross-site scripting vulnerability in HeliumEdu platform, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

Helium is a free online student planner for classes, homework, grades, and notes. Prior to 2.2.60, the POST /planner/attachments/ endpoint allows authenticated users to upload SVG and HTML attachments because conf/configs/common.py omits those formats from BLOCKED_ATTACHMENT_EXTENSIONS and BLOCKED_ATTACHMENT_MIME_TYPES, and helium/planner/serializers/attachmentserializer.py relies on those blocklists. An uploaded SVG served as image/svg+xml can execute embedded script when a visitor opens its public attachment URL, allowing persistent attacker-controlled active content and phishing under an application-managed storage URL. The attachment storage uses a separate origin from the application, so same-origin policy prevents the script from reading application cookies or storage, and application-session compromise is not supported by the maintained deployment configuration. This issue is fixed in version 2.2.60.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55876?


## How do I fix CVE-2026-55876?

No fix has been published for CVE-2026-55876 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-55876 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55876 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55876 and fix it if it is affected.

What it is: CVE-2026-55876 is a low-severity cross-site scripting vulnerability in HeliumEdu platform, published on 15 Oct 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55876 exists.

Affected product: HeliumEdu platform. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55876/ (Markdown: https://insights.sbomify.com/CVE-2026-55876/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55876
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55876
- OSV: https://osv.dev/vulnerability/CVE-2026-55876

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55876/
Summaries are generated and may contain mistakes; the official description above is the record.
