# CVE-2026-55877: Symfony UX: XSS in symfony/ux-icons via unsanitized SVG content in local files and Iconify on-demand responses

> Attackers can execute cross-site scripting via unsanitized SVG content in Symfony UX Icons, requiring an upgrade to patched versions.

- **Severity:** Medium 6.1 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 8 Jul 2026
- **Updated:** 9 Jul 2026
- **Also known as:** GHSA-6v8j-33hc-mv84

## What is CVE-2026-55877?

CVE-2026-55877 is a medium-severity cross-site scripting vulnerability in symfony ux, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.

### Official description

Symfony UX is a JavaScript ecosystem for Symfony. From 2.17.0 before 2.36.1 and from 3.0.0 before 3.2.0, the ux_icon() Twig function is marked is_safe=['html'] and Icon::toHtml() inlines SVG source verbatim, allowing unsanitized local SVG files or Iconify on-demand JSON body responses containing nested script elements, on* event handlers, or dangerous URL schemes to execute cross-site scripting. This issue is fixed in versions 2.36.1 and 3.2.0.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55877?

4 open source packages ship an affected version, including symfony/ux-icons. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `symfony/ux-icons` | Packagist | From 2.17.0 | 2.36.1 |
| `symfony/ux-icons` | Packagist | From 2.17.0 | 2.36.1 |
| `symfony/ux-icons` | Packagist | From 3.0.0 | 3.2.0 |
| `symfony/ux-icons` | Packagist | From 3.0.0 | 3.2.0 |

Products: Symfony Ux.

## How do I fix CVE-2026-55877?

Upgrade symfony/ux-icons to a fixed version for your release line: 2.36.1 or 3.2.0.

## Is CVE-2026-55877 being exploited?

There is no known exploitation of CVE-2026-55877 in the wild and no public exploit code.

## Other vulnerabilities in symfony ux

- [CVE-2026-49208](https://insights.sbomify.com/CVE-2026-49208/): Symfony UX: Format-less date LiveProps parsed with the permissive DateTime constructor (medium 6.9)
- [CVE-2026-49211](https://insights.sbomify.com/CVE-2026-49211/): Symfony UX: Information exposure via unescaped LIKE wildcards in EntitySearchUtil (medium 6.9)
- [CVE-2026-49212](https://insights.sbomify.com/CVE-2026-49212/): Symfony UX: LiveComponentHydrator HMAC checksum lacks component and slot binding (medium 6.9)
- [CVE-2026-49209](https://insights.sbomify.com/CVE-2026-49209/): Symfony UX: Denial of service in symfony/ux-live-component via unbounded batch action requests (medium 5.3)
- [CVE-2026-49216](https://insights.sbomify.com/CVE-2026-49216/): Symfony UX: XSS in symfony/ux-autocomplete via unescaped AJAX response data (medium 5.1)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55877 and fix it if it is affected.

What it is: CVE-2026-55877 is a medium-severity cross-site scripting vulnerability in symfony ux, published on 8 Jul 2026. An attacker can exploit it over the internet without logging in, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-55877 in the wild and no public exploit code.

Affected packages and fixed versions:
- symfony/ux-icons (Packagist): affected from 2.17.0; fixed in 2.36.1
- symfony/ux-icons (Packagist): affected from 2.17.0; fixed in 2.36.1
- symfony/ux-icons (Packagist): affected from 3.0.0; fixed in 3.2.0
- symfony/ux-icons (Packagist): affected from 3.0.0; fixed in 3.2.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55877/ (Markdown: https://insights.sbomify.com/CVE-2026-55877/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55877
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55877
- OSV: https://osv.dev/vulnerability/CVE-2026-55877

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55877/
Summaries are generated and may contain mistakes; the official description above is the record.
