# CVE-2026-5588: PKIX draft CompositeVerifier accepts empty signature sequence as valid.

> The Bouncy Castle Java library incorrectly accepts empty signature sequences as valid, allowing attackers to bypass cryptographic verification checks.

- **Severity:** Medium 6.3 (`CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N/U:Amber`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 15 Apr 2026
- **Updated:** 18 Sep 2026
- **Also known as:** CLEANSTART-2026-OX95467, CLEANSTART-2026-XR61334, DEBIAN-CVE-2026-5588, ECHO-e567-eb6f-d89b, GHSA-wg6q-6289-32hp, MINI-2fmj-85mm-77mq, MINI-2jc4-mwcr-prh6, MINI-2jc6-3x25-2f5c, MINI-2q2v-fp73-fwv7, MINI-2xhp-w4p8-4wq8, MINI-3xx8-r66r-3cwq, MINI-488x-8pwv-c9gj, MINI-4ghv-fc7w-9fx8, MINI-4pmp-c3pc-wf79, MINI-4r5w-v57c-w266, MINI-4x74-h5p8-qj69, MINI-5cgm-g2qq-3fwv, MINI-6455-vphm-qq9q, MINI-69cj-9r49-274f, MINI-87c2-q7jx-27wg, MINI-8rr4-9wwg-ww92, MINI-92rc-77wq-8jxv, MINI-968w-c5rh-crfc, MINI-9758-72cf-mg3c, MINI-9qfp-5rhj-5fcj, MINI-9r42-3843-wmw6, MINI-9w79-rh32-rp4q, MINI-c8p8-j6fj-vr54, MINI-cjc2-5qc4-8m7f, MINI-cpc5-cc5h-w827, MINI-ffc4-pfv9-57rp, MINI-gg7q-g42p-4rxf, MINI-hqv9-cvwj-m9h3, MINI-jpgc-498j-j779, MINI-mv37-xqxp-8wgj, MINI-p5f6-p37p-c273, MINI-p7w5-35pc-89p9, MINI-pfrv-5h4x-v776, MINI-pj3v-pv8q-8chm, MINI-pmcx-4x22-9655, MINI-pwr9-8w5f-h2mg, MINI-qqpg-jgr3-c857, MINI-r39c-vvvr-7pqw, MINI-r86j-72hj-jv2m, MINI-vhvg-fp62-rwh4, MINI-wm5f-3r9f-28vv, MINI-wwf3-x2r5-4pmw, MINI-x47p-x99x-823f, MINI-x72r-p78w-j6c5, MINI-xjcw-3mwc-27c9, MINI-xqwr-v5rg-phrw, MINI-xrr7-68xc-w3jc, ROOT-APP-MAVEN-CVE-2026-5588, UBUNTU-CVE-2026-5588

## What is CVE-2026-5588?

CVE-2026-5588 is a medium-severity vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Use of a Broken or Risky Cryptographic Algorithm vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA bcpkix on all (pkix modules), Legion of the Bouncy Castle Inc. BCPKIX-FIPS bcpkix on All (pkix modules), Legion of the Bouncy Castle Inc. BCPIX-LTS bcpkix on All (pkix modules).

 This vulnerability is associated with program files JcaContentVerifierProviderBuilder.Java, JcaContentVerfierProviderBuilder.Java.

This issue affects BC-JAVA: from 1.67 before 1.80.2, from 1.81 before 1.81.1, from 1.82 before 1.84; BCPKIX-FIPS: from 2.0.6 before 2.0.11, from 2.1.7 before 2.1.11; BCPIX-LTS: from 2.73.7 before 2.73.11.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature), CWE-327 (Use of a Broken or Risky Cryptographic Algorithm)

## Which versions are affected by CVE-2026-5588?

14 open source packages ship an affected version, including org.bouncycastle:bcpkix-debug-jdk14, org.bouncycastle:bcpkix-debug-jdk15to18 and org.bouncycastle:bcpkix-debug-jdk18on.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.bouncycastle:bcpkix-debug-jdk14` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-debug-jdk14` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-debug-jdk15to18` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-debug-jdk15to18` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-debug-jdk18on` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-debug-jdk18on` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk14` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk14` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk15on` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk15on` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk15to18` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk15to18` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk18on` | Maven | From 1.49 | 1.84 |
| `org.bouncycastle:bcpkix-jdk18on` | Maven | From 1.49 | 1.84 |

## How do I fix CVE-2026-5588?

Upgrade org.bouncycastle:bcpkix-debug-jdk14 to 1.84 or later.

## Is CVE-2026-5588 being exploited?

There is no known exploitation of CVE-2026-5588 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5588 and fix it if it is affected.

What it is: CVE-2026-5588 is a medium-severity vulnerability in Legion of the Bouncy Castle Inc. BC-JAVA, published on 15 Apr 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5588 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.bouncycastle:bcpkix-debug-jdk14 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-debug-jdk14 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-debug-jdk15to18 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-debug-jdk15to18 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-debug-jdk18on (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-debug-jdk18on (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk14 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk14 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk15on (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk15on (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk15to18 (Maven): affected from 1.49; fixed in 1.84
- org.bouncycastle:bcpkix-jdk15to18 (Maven): affected from 1.49; fixed in 1.84

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5588/ (Markdown: https://insights.sbomify.com/CVE-2026-5588/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5588
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5588
- OSV: https://osv.dev/vulnerability/CVE-2026-5588

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5588/
Summaries are generated and may contain mistakes; the official description above is the record.
