# CVE-2026-55885: Grav: Admin Backup Zip File Exposes Account Credentials and Configuration Secrets

> Authenticated administrators can download backup archives exposing password hashes and configuration secrets, potentially leading to account takeover.

- **Severity:** Medium 6.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 14 Jul 2026
- **Also known as:** GHSA-2f86-9cp8-6hcf

## What is CVE-2026-55885?

CVE-2026-55885 is a medium-severity vulnerability in getgrav grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

Grav is a file-based Web platform. Prior to 1.7.53, an authenticated administrator with backup permissions can download a ZIP archive containing the full Grav installation root, including user/accounts/admin.yaml with the administrator password hash and user/config with site configuration, through the backup download endpoint protected only by the session-static admin-nonce URL parameter. This issue is reported as fixed in version 1.7.53.

Weakness: CWE-522 (Insufficiently Protected Credentials), CWE-312 (Cleartext Storage of Sensitive Information)

## Which versions are affected by CVE-2026-55885?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 1.7.53 |
| `getgrav/grav` | Packagist | All versions | 1.7.53 |

## How do I fix CVE-2026-55885?

Upgrade getgrav/grav to 1.7.53 or later.

## Is CVE-2026-55885 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55885 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55885 and fix it if it is affected.

What it is: CVE-2026-55885 is a medium-severity vulnerability in getgrav grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55885 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.53
- getgrav/grav (Packagist): affected all versions; fixed in 1.7.53

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55885/ (Markdown: https://insights.sbomify.com/CVE-2026-55885/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55885
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55885
- OSV: https://osv.dev/vulnerability/CVE-2026-55885

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55885/
Summaries are generated and may contain mistakes; the official description above is the record.
