# CVE-2026-55890: Grav: Stored CSS injection via Markdown image ?style=… reaches MediaObjectTrait::style()

> Attackers can inject malicious CSS via Markdown image styles in Grav, potentially leading to script execution or session hijacking.

- **Severity:** Medium 4.8 (`CVSS:3.1/AV:N/AC:L/PR:H/UI:R/S:C/C:L/I:L/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 10 Jul 2026
- **Updated:** 10 Jul 2026
- **Also known as:** GHSA-pmf8-g7c8-7v54

## What is CVE-2026-55890?

CVE-2026-55890 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.

### Official description

Grav is a file-based Web platform. Prior to 2.0.0-rc.9, Grav's incomplete fix for stored XSS through the Markdown media attribute action (CVE-2026-42841) leaves the sibling MediaObjectTrait::style method reachable through the same Markdown excerpt-action pipeline, allowing an editor to save Markdown image style parameters that are written into the rendered img style attribute without sanitization. This issue is fixed in version 2.0.0-rc.9.

Weakness: CWE-79 (Improper Neutralization of Input During Web Page Generation)

## Which versions are affected by CVE-2026-55890?

2 open source packages ship an affected version, including getgrav/grav.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `getgrav/grav` | Packagist | All versions | 2.0.0-rc.9 |
| `getgrav/grav` | Packagist | All versions | 2.0.0-rc.9 |

## How do I fix CVE-2026-55890?

Upgrade getgrav/grav to 2.0.0-rc.9 or later.

## Is CVE-2026-55890 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55890 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55890 and fix it if it is affected.

What it is: CVE-2026-55890 is a medium-severity cross-site scripting vulnerability in getgrav grav, published on 10 Jul 2026. An attacker needs administrator access to exploit it, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55890 exists.

Affected packages and fixed versions:
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-rc.9
- getgrav/grav (Packagist): affected all versions; fixed in 2.0.0-rc.9

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55890/ (Markdown: https://insights.sbomify.com/CVE-2026-55890/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55890
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55890
- OSV: https://osv.dev/vulnerability/CVE-2026-55890

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55890/
Summaries are generated and may contain mistakes; the official description above is the record.
