CVE-2026-55897 luci-app-advanced-reboot read ACL exposes /bin/sh through file.exec, allowing delegated users to run commands as root
Authenticated users can execute arbitrary commands as root via the advanced reboot plugin's exposed shell execution permission.
- Exploited in the wild
- Not known
- Login needed
- Any signed-in user
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- None listed
What is CVE-2026-55897?
CVE-2026-55897 is a high-severity command injection vulnerability in openwrt luci, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Official description
luci-app-advanced-reboot is a LuCI (web interface) application for OpenWrt that provides a way to reboot your router into an alternative firmware partition or perform reboot operations directly from the web UI. Prior to 1.1.2-6, the luci-app-advanced-reboot read ACL in applications/luci-app-advanced-reboot/root/usr/share/rpcd/acl.d/luci-app-advanced-reboot.json grants rpcd file.exec permission for the general shell interpreter /bin/sh. An authenticated delegated session with that read ACL can supply caller-controlled params; rpcd authorizes the executable path and passes those arguments to the shell, allowing arbitrary commands to execute as root. Builds without the /bin/sh exec grant, including the checked openwrt-24.10 and openwrt-23.05 branches, are not affected by this specific chain. This vulnerability is fixed in 1.1.2-6.
Weakness: CWE-78
Which versions are affected by CVE-2026-55897?
How do I fix CVE-2026-55897?
No fix has been published for CVE-2026-55897 yet. Limit exposure of the affected software until one is available.
Upgrade, and pass arguments to programs as a list instead of through a shell. More about Command injection.
Is CVE-2026-55897 being exploited?
It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55897 exists.
Sources
Also known as GHSA-vj96-f37g-37f6.