{"answers":{"affected":"","exploited":"It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55897 exists.","fix":"No fix has been published for CVE-2026-55897 yet. Limit exposure of the affected software until one is available.","what":"CVE-2026-55897 is a high-severity command injection vulnerability in openwrt luci, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-55897 and fix it if it is affected.\n\nWhat it is: CVE-2026-55897 is a high-severity command injection vulnerability in openwrt luci, published on 21 Sep 2026. Any signed-in user can exploit it over the network, with no action from the victim.\nExploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-55897 exists.\n\nAffected product: openwrt luci. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-55897/ (Markdown: https://insights.sbomify.com/CVE-2026-55897/index.md)","id":"CVE-2026-55897","markdown":"https://insights.sbomify.com/CVE-2026-55897/index.md","name":"CVE-2026-55897","record":{"aliases":["GHSA-vj96-f37g-37f6"],"analysis":{"component_type":"web_application","fix_type":"upgrade","impacts":["code_execution","privilege_escalation"],"network_reachable":"yes","non_default_config":false,"product_category":"OpenWrt LuCI plugin","requires_auth":"low_privilege","summary":"Authenticated users can execute arbitrary commands as root via the advanced reboot plugin's exposed shell execution permission.","user_interaction":"not_required","vuln_class":"command_injection"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"GitHub_M","cpe":[],"cvss":{"score":8.8,"severity":"high","source":"cna","vector":"CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H","version":"3.1"},"cwes":[{"id":"CWE-78","name":"Improper Neutralization of Special Elements used in an OS Command"}],"description":"luci-app-advanced-reboot is a LuCI (web interface) application for OpenWrt that provides a  way to reboot your router into an alternative firmware partition or perform  reboot operations directly from the web UI. Prior to 1.1.2-6, the luci-app-advanced-reboot read ACL in applications/luci-app-advanced-reboot/root/usr/share/rpcd/acl.d/luci-app-advanced-reboot.json grants rpcd file.exec permission for the general shell interpreter /bin/sh. An authenticated delegated session with that read ACL can supply caller-controlled params; rpcd authorizes the executable path and passes those arguments to the shell, allowing arbitrary commands to execute as root. Builds without the /bin/sh exec grant, including the checked openwrt-24.10 and openwrt-23.05 branches, are not affected by this specific chain. This vulnerability is fixed in 1.1.2-6.","ecosystems":[],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"weaponised"},"has_fix":false,"headline":"luci-app-advanced-reboot read ACL exposes /bin/sh through file.exec, allowing delegated users to run commands as root","id":"CVE-2026-55897","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"command_injection","year":"2026"},"n_packages":0,"n_references":4,"next":{"headline":"Microsoft Excel Information Disclosure Vulnerability","id":"CVE-2026-55898"},"packages":[],"prev":{"headline":"Vim: Vimscript Code Injection in netrw NetrwLocalRmFile() via crafted filename","id":"CVE-2026-55895"},"products":["luci"],"published":"2026-09-21","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"poc","technical_impact":"total"},"state":"PUBLISHED","updated":"2026-09-21","vendors":["openwrt"]},"summary":"Authenticated users can execute arbitrary commands as root via the advanced reboot plugin's exposed shell execution permission.","url":"https://insights.sbomify.com/CVE-2026-55897/"}