CVE-2026-55955 Apache Tomcat: EncryptInterceptor not protected against replay attacks
Attackers can bypass authentication in Apache Tomcat clusters by replaying encrypted messages, requiring cluster encryption to be enabled.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55955?
CVE-2026-55955 is a medium-severity authentication bypass vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authentication vulnerability in Apache Tomcat allowed a replay attack against the EncryptionInterceptor in the cluster component.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.13 through 9.0.18, from 8.5.38 through 8.5.100, from 7.0.100 through 7.0.109.
Users are recommended to upgrade to version 11.0.23, 10.1.56, 9.0.119, which fixes the issue.
Weakness: CWE-287
Which versions are affected by CVE-2026-55955?
1 open source package ship an affected version, including tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | All versions | 9.0.119, 10.1.56, 11.0.23 |
Products include Apache Tomcat.
How do I fix CVE-2026-55955?
Upgrade tomcat to a fixed version for your release line: 9.0.119, 10.1.56 or 11.0.23.
Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.
Is CVE-2026-55955 being exploited?
There is no known exploitation of CVE-2026-55955 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-55955, CLSA-2026-1785497476, DEBIAN-CVE-2026-55955, GHSA-c5ph-rghf-fjfj, UBUNTU-CVE-2026-55955.