CVE-2026-55956 Apache Tomcat: Security constraints for default servlet ignored method
Attackers can bypass security constraints on the default servlet by exploiting ignored method configurations, potentially accessing restricted resources.
- Exploited in the wild
- Not known
- Login needed
- Not needed
- Attackable
- Over the internet
- Victim action needed
- Not needed
- Fix
- Available
What is CVE-2026-55956?
CVE-2026-55956 is a medium-severity missing authorization vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Official description
Improper Authorization vulnerability in Apache Tomcat leads to security constraints specified for the default servlet ignoring any method or method omission configured as part of the constraint.
This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.22, from 10.1.0-M1 through 10.1.55, from 9.0.0.M1 through 9.0.118, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109. Other versions that have reached end of support may also be affected.
Users are recommended to upgrade to version 11.0.23, 10.1.56 or 9.0.119, which fix the issue.
Weakness: CWE-285
Which versions are affected by CVE-2026-55956?
1 open source package ship an affected version, including tomcat. It affects 1 product.
| Package | Affected | Fixed in |
|---|---|---|
tomcat Bitnami | All versions | 9.0.119, 10.1.56, 11.0.23 |
Products include Apache Tomcat.
How do I fix CVE-2026-55956?
Upgrade tomcat to a fixed version for your release line: 9.0.119, 10.1.56 or 11.0.23.
Upgrade, and check permissions on every request on the server, not only in the interface. More about Missing authorization.
Is CVE-2026-55956 being exploited?
There is no known exploitation of CVE-2026-55956 in the wild and no public exploit code.
Other vulnerabilities in Apache Tomcat
Sources
Also known as BIT-tomcat-2026-55956, DEBIAN-CVE-2026-55956, GHSA-5v3h-fjv2-54fg, UBUNTU-CVE-2026-55956.