# CVE-2026-55957: Apache Tomcat: Authentication bypass with JNDIRealm and GSSAPI authenticated bind

> Attackers can bypass authentication in Apache Tomcat when JNDIRealm is configured for GSSAPI binds, allowing unauthorized access without a correct password.

- **Severity:** High 7.3 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:L/A:L`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 29 Jun 2026
- **Updated:** 30 Jun 2026
- **Also known as:** BIT-tomcat-2026-55957, CLSA-2026-1783522891, CLSA-2026-1783591320, CLSA-2026-1784541319, CLSA-2026-1785309072, CLSA-2026-1786880824, CLSA-2026-1786880926, DEBIAN-CVE-2026-55957, GHSA-7895-gffq-w6jq, UBUNTU-CVE-2026-55957

## What is CVE-2026-55957?

CVE-2026-55957 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Missing Critical Step in Authentication vulnerability in Apache Tomcat when the JNDIRealm was configured to authenticate binds using GSSAPI allowed attackers to authenticate without provided the correct password.

This issue affects Apache Tomcat: from 11.0.0-M1 through 11.0.4, from 10.1.0-M1 through 10.1.36, from 9.0.0.M1 through 9.0.100, from 8.5.0 through 8.5.100, from 7.0.0 through 7.0.109.

Users are recommended to upgrade to version 11.0.5, 10.1.37 or 9.0.101, which fixes the issue.

Weakness: CWE-304 (Missing Critical Step in Authentication)

## Which versions are affected by CVE-2026-55957?

1 open source package ship an affected version, including tomcat. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `tomcat` | Bitnami | All versions | 9.0.101, 10.1.37, 11.0.5 |

Products: Apache Tomcat.

## How do I fix CVE-2026-55957?

Upgrade tomcat to a fixed version for your release line: 9.0.101, 10.1.37 or 11.0.5.

## Is CVE-2026-55957 being exploited?

There is no known exploitation of CVE-2026-55957 in the wild and no public exploit code.

Public exploit code:

- Reproducible Docker lab for the Apache Tomcat JNDIRealm GSSAPI authentication bypass (github_poc): https://github.com/mdvpat/CVE-2026-55957-PoC

## Other vulnerabilities in Apache Tomcat

- [CVE-2025-24813](https://insights.sbomify.com/CVE-2025-24813/): Apache Tomcat Path Equivalence (critical 10.0, exploited in the wild)
- [CVE-2016-8735](https://insights.sbomify.com/CVE-2016-8735/): Apache Tomcat Remote Code Execution (critical 9.8, exploited in the wild)
- [CVE-2017-12617](https://insights.sbomify.com/CVE-2017-12617/): Apache Tomcat Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2017-12615](https://insights.sbomify.com/CVE-2017-12615/): Apache Tomcat on Windows Remote Code Execution (high 8.1, exploited in the wild)
- [CVE-2026-34486](https://insights.sbomify.com/CVE-2026-34486/): Apache Tomcat Missing Encryption of Sensitive Data (high 7.5, exploited in the wild)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55957 and fix it if it is affected.

What it is: CVE-2026-55957 is a high-severity authentication bypass vulnerability in Apache Tomcat, published on 29 Jun 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55957 in the wild and no public exploit code.

Affected packages and fixed versions:
- tomcat (Bitnami): affected all versions; fixed in 9.0.101, 10.1.37, 11.0.5

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55957/ (Markdown: https://insights.sbomify.com/CVE-2026-55957/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55957
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55957
- OSV: https://osv.dev/vulnerability/CVE-2026-55957

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55957/
Summaries are generated and may contain mistakes; the official description above is the record.
