# CVE-2026-55968: Apache Thrift: Node.js quadratic-time DoS in server receive transports

> An attacker can cause a denial of service in Apache Thrift Node.js servers by exploiting inefficient algorithmic complexity in receive transports.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** BIT-thrift-2026-55968, DEBIAN-CVE-2026-55968, GHSA-8cj2-994r-9fpq, MINI-xxhw-wqf4-w986, UBUNTU-CVE-2026-55968

## What is CVE-2026-55968?

CVE-2026-55968 is a high-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Inefficient Algorithmic Complexity, Allocation of Resources Without Limits or Throttling vulnerability in Apache Thrift Node.js bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-770 (Allocation of Resources Without Limits or Throttling), CWE-407 (Inefficient Algorithmic Complexity)

## Which versions are affected by CVE-2026-55968?

1 open source package ship an affected version, including thrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.24.0 |

Products: Apache Thrift.

## How do I fix CVE-2026-55968?

Upgrade thrift to 0.24.0 or later.

## Is CVE-2026-55968 being exploited?

There is no known exploitation of CVE-2026-55968 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55968 and fix it if it is affected.

What it is: CVE-2026-55968 is a high-severity denial of service vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55968 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55968/ (Markdown: https://insights.sbomify.com/CVE-2026-55968/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55968
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55968
- OSV: https://osv.dev/vulnerability/CVE-2026-55968

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55968/
Summaries are generated and may contain mistakes; the official description above is the record.
