# CVE-2026-55969: Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings.


- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:N/VI:N/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Fix available:** Yes
- **Published:** 27 Jul 2026
- **Updated:** 27 Jul 2026
- **Also known as:** AZL-93992, AZL-94160, AZL-94217, AZL-94232, AZL-94317, AZL-94332, BIT-thrift-2026-55969, DEBIAN-CVE-2026-55969, ECHO-61d4-277d-88d0, GHSA-x8jh-qfcv-fp29, MINI-qp77-7q24-p67f, UBUNTU-CVE-2026-55969

## What is CVE-2026-55969?

CVE-2026-55969 is a high-severity vulnerability in Apache Thrift, published on 27 Jul 2026. 

### Official description

Integer Overflow or Wraparound vulnerability in Apache Thrift C++, c_glib, Go, netstd, Delphi and Haxe bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-190 (Integer Overflow or Wraparound)

## Which versions are affected by CVE-2026-55969?

1 open source package ship an affected version, including thrift. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `thrift` | Bitnami | All versions | 0.24.0 |

Products: Apache Thrift.

## How do I fix CVE-2026-55969?

Upgrade thrift to 0.24.0 or later.

## Is CVE-2026-55969 being exploited?

There is no known exploitation of CVE-2026-55969 in the wild and no public exploit code.

## Other vulnerabilities in Apache Thrift

- [CVE-2026-55971](https://insights.sbomify.com/CVE-2026-55971/): Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform() (critical 9.3)
- [CVE-2026-48144](https://insights.sbomify.com/CVE-2026-48144/): Apache Thrift: c_glib TLS Client Missing Hostname Verification (critical 9.1)
- [CVE-2016-5397](https://insights.sbomify.com/CVE-2016-5397/): Apache Thrift Go Library Command Injection (high 8.8)
- [CVE-2026-43871](https://insights.sbomify.com/CVE-2026-43871/): Apache Thrift, Apache Thrift, Apache Thrift, Apache Thrift: TCompactProtocol varint byte-count limit (high 8.7)
- [CVE-2026-48586](https://insights.sbomify.com/CVE-2026-48586/): Denial of service in Apache Thrift (high 8.7)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55969 and fix it if it is affected.

What it is: CVE-2026-55969 is a high-severity vulnerability in Apache Thrift, published on 27 Jul 2026. 
Exploitation: There is no known exploitation of CVE-2026-55969 in the wild and no public exploit code.

Affected packages and fixed versions:
- thrift (Bitnami): affected all versions; fixed in 0.24.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55969/ (Markdown: https://insights.sbomify.com/CVE-2026-55969/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55969
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55969
- OSV: https://osv.dev/vulnerability/CVE-2026-55969

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55969/
Summaries are generated and may contain mistakes; the official description above is the record.
