CVE-2026-55971 Apache Thrift: C++ ZLIB heap buffer overflow (write) in THeaderTransport::untransform()

Critical 9.3 Published Updated

A heap buffer overflow in Apache Thrift C++ bindings allows attackers to execute arbitrary code or cause denial of service.

Exploited in the wild
Not known
Login needed
Not needed
Attackable
Over the internet
Victim action needed
Not needed
Fix
Available

What is CVE-2026-55971?

CVE-2026-55971 is a critical memory corruption vulnerability in Apache Thrift, published on 27 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

Official description

Heap-based Buffer Overflow vulnerability in Apache Thrift C++ bindings.

This issue affects Apache Thrift: before 0.24.0.

Users are recommended to upgrade to version 0.24.0, which fixes the issue.

Weakness: CWE-122

Which versions are affected by CVE-2026-55971?

1 open source package ship an affected version, including thrift. It affects 1 product.

PackageAffectedFixed in
thrift BitnamiAll versions0.24.0
Linux distribution packages (36)
perl-thrift Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
python3-thrift Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
python3-thrift-debuginfo Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-debuginfo Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-debugsource Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-devel Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-devel-debuginfo Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-glib Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-glib-debuginfo Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-qt Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
thrift-qt-debuginfo Red Hat:enterprise_linux_ai:3.4::el9All versions0:0.24.0-1.el9ai
perl-thrift Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
python3-thrift Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
python3-thrift-debuginfo Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-debuginfo Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-debugsource Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-devel Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-devel-debuginfo Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-glib Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-glib-debuginfo Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-qt Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
thrift-qt-debuginfo Red Hat:enterprise_linux_ai:3.5::el9All versions0:0.24.0-1.el9ai
perl-thrift Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
python3-thrift Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
python3-thrift-debuginfo Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-debuginfo Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-debugsource Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-devel Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-devel-debuginfo Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-glib Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-glib-debuginfo Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-qt Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai
thrift-qt-debuginfo Red Hat:enterprise_linux_ai:3.6::el9All versions0:0.24.0-2.el9ai

Products include Apache Thrift.

How do I fix CVE-2026-55971?

Upgrade thrift to 0.24.0 or later.

Upgrade to the fixed version. Memory-safe languages, compiler hardening and fuzzing prevent most new cases. More about Memory corruption.

Is CVE-2026-55971 being exploited?

There is no known exploitation of CVE-2026-55971 in the wild and no public exploit code.

Sources

Also known as AZL-94007, BIT-thrift-2026-55971, DEBIAN-CVE-2026-55971, ECHO-bda0-5769-1551, GHSA-gwj4-q93m-wwqc, MINI-qhx4-gcx9-4fpg and 4 more.

Is CVE-2026-55971 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free