# CVE-2026-55994: Apache Camel-Iggy: The inbound consumer maps externally-supplied Iggy message user-headers into the Exchange without a HeaderFilterStrategy

> Attackers can inject Camel control headers via Iggy messages to trigger SSRF and disclose sensitive environment variables or secrets.

- **Severity:** High 7.5 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 6 Jul 2026
- **Updated:** 6 Jul 2026
- **Also known as:** GHSA-pw9q-pq7c-rfqw

## What is CVE-2026-55994?

CVE-2026-55994 is a high-severity server-side request forgery vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Improper Input Validation, Exposure of Sensitive Information to an Unauthorized Actor, Server-Side Request Forgery (SSRF) vulnerability in Apache Camel in Iggy component.

The camel-iggy consumer mapped the user-headers of inbound Iggy messages into the Camel Exchange header map without applying any HeaderFilterStrategy (IggyFetchRecords copied the message user-headers straight into the Exchange). Because nothing blocked the Camel header namespace, an actor able to publish to the consumed Iggy stream/topic could set Camel-internal control headers - including CamelHttpUri (Exchange.HTTP_URI) - simply by supplying them as message user-headers. In a route where the Iggy consumer feeds a downstream HTTP producer, the injected CamelHttpUri redirects the server-side HTTP request to an attacker-chosen destination (server-side request forgery - for example to an internal service or a cloud metadata endpoint). In addition, the HTTP producer resolves Camel property placeholders on the resulting (attacker-controlled) URI, so placeholders embedded in the injected value - such as an environment-variable reference, an application property, or a vault reference - are resolved to their real values and sent to the attacker, disclosing environment variables, application properties and vault secrets.
This issue affects Apache Camel: from 4.17.0 before 4.18.3, from 4.19.0 before 4.21.0.

Users are recommended to upgrade to version 4.21.0, which fixes the issue. If users are on the 4.18.x releases stream, then they are suggested to upgrade to 4.18.3. The fix adds a dedicated IggyHeaderFilterStrategy (and a headerFilterStrategy endpoint option) that filters the Camel header namespace case-insensitively on inbound mapping, so externally-supplied Camel* / camel* headers are no longer copied into the Exchange. For deployments that cannot upgrade immediately, strip the Camel control headers from the inbound message before they reach any downstream producer (for example removeHeaders('Camel*') and removeHeaders('camel*') at the start of the route), restrict who can publish to the consumed Iggy stream/topic, and avoid bridging an untrusted consumer directly into an HTTP producer whose target URI can be driven from message headers.

Weakness: CWE-918 (Server-Side Request Forgery), CWE-200 (Exposure of Sensitive Information to an Unauthorized Actor), CWE-20 (Improper Input Validation)

## Which versions are affected by CVE-2026-55994?

4 open source packages ship an affected version, including org.apache.camel:camel-iggy. It affects 1 product.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `org.apache.camel:camel-iggy` | Maven | From 4.17.0 | 4.18.3 |
| `org.apache.camel:camel-iggy` | Maven | From 4.17.0 | 4.18.3 |
| `org.apache.camel:camel-iggy` | Maven | From 4.19.0 | 4.21.0 |
| `org.apache.camel:camel-iggy` | Maven | From 4.19.0 | 4.21.0 |

Products: Apache Camel.

## How do I fix CVE-2026-55994?

Upgrade org.apache.camel:camel-iggy to a fixed version for your release line: 4.18.3 or 4.21.0.

## Is CVE-2026-55994 being exploited?

There is no known exploitation of CVE-2026-55994 in the wild and no public exploit code.

Public exploit code:

- PoC reproducer for CVE-2026-55994 (Apache Camel camel-iggy): the consumer copies an Iggy message's user-headers onto the Exchange unfiltered, so an injected CamelHttpUri drives a server-side request (SSRF) and leaks resolved property placeholders. Fixed in 4.18.3/4.21.0. (github_poc): https://github.com/oscerd/CVE-2026-55994

## Other vulnerabilities in Apache Camel

- [CVE-2026-33453](https://insights.sbomify.com/CVE-2026-33453/): Apache camel-coap allows header injection that can lead to remote code execution (critical 10.0)
- [CVE-2026-40453](https://insights.sbomify.com/CVE-2026-40453/): Apache Camel has an incomplete fix for CVE-2025-27636 (critical 9.9)
- [CVE-2026-80351](https://insights.sbomify.com/CVE-2026-80351/): Apache Camel K: Camel K Tenant repositories reach Maven execution inside operator pod (critical 9.8)
- [CVE-2026-80352](https://insights.sbomify.com/CVE-2026-80352/): Apache Camel K: Camel K Master trait serviceAccountName YAML injection lets CR author apply arbitrary objects (critical 9.8)
- [CVE-2026-71300](https://insights.sbomify.com/CVE-2026-71300/): Apache Camel: Camel-Atmosphere-Websocket: WebSocket dispatch header injection (critical 9.8)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-55994 and fix it if it is affected.

What it is: CVE-2026-55994 is a high-severity server-side request forgery vulnerability in Apache Camel, published on 6 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-55994 in the wild and no public exploit code.

Affected packages and fixed versions:
- org.apache.camel:camel-iggy (Maven): affected from 4.17.0; fixed in 4.18.3
- org.apache.camel:camel-iggy (Maven): affected from 4.17.0; fixed in 4.18.3
- org.apache.camel:camel-iggy (Maven): affected from 4.19.0; fixed in 4.21.0
- org.apache.camel:camel-iggy (Maven): affected from 4.19.0; fixed in 4.21.0

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-55994/ (Markdown: https://insights.sbomify.com/CVE-2026-55994/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-55994
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-55994
- OSV: https://osv.dev/vulnerability/CVE-2026-55994

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-55994/
Summaries are generated and may contain mistakes; the official description above is the record.
