{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-56016 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-56016 is a medium-severity vulnerability in MARKSTOS CGI::Session::ID::md5, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56016 and fix it if it is affected.\n\nWhat it is: CVE-2026-56016 is a medium-severity vulnerability in MARKSTOS CGI::Session::ID::md5, published on 1 Jul 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56016 in the wild and no public exploit code.\n\nAffected product: MARKSTOS CGI::Session::ID::md5. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56016/ (Markdown: https://insights.sbomify.com/CVE-2026-56016/index.md)","id":"CVE-2026-56016","markdown":"https://insights.sbomify.com/CVE-2026-56016/index.md","name":"CVE-2026-56016","record":{"aliases":["ALPINE-CVE-2026-56016","DEBIAN-CVE-2026-56016","GHSA-r49c-4q8x-x33v","MGASA-2026-0286","UBUNTU-CVE-2026-56016","openSUSE-SU-2026:11168-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["account_takeover","security_bypass"],"network_reachable":"yes","non_default_config":false,"product_category":"Perl session library","requires_auth":"none","summary":"Attackers can predict session IDs due to low-entropy generation, allowing them to impersonate users and bypass authentication in Perl applications.","user_interaction":"not_required","vuln_class":"weak_cryptography"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"CPANSec","cpe":[],"cvss":{"score":5.9,"severity":"medium","source":"cisa-adp","vector":"CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N","version":"3.1"},"cwes":[{"id":"CWE-340","name":"Generation of Predictable Numbers or Identifiers"},{"id":"CWE-338","name":"Use of Cryptographically Weak Pseudo-Random Number Generator (PRNG)"}],"description":"CGI::Session::ID::md5 versions before 4.49 for Perl generate predictable session ids from low-entropy sources.\n\nThe generate_id method builds the session id from a MD5 digest of the process id, the epoch time, and the built-in rand() function. All three are predictable, low-entropy sources: the PID is drawn from a small range, the epoch time can be guessed or read from the HTTP Date header, and Perl's rand() is unsuitable for security purposes because it is predictable and reversible.\n\nAn attacker who predicts a session id can impersonate the corresponding session and bypass authentication.","ecosystems":["openSUSE:Tumbleweed"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"CGI::Session::ID::md5 versions before 4.49 for Perl generate predictable session ids from low-entropy sources","id":"CVE-2026-56016","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"weak_cryptography","year":"2026"},"n_packages":1,"n_references":2,"next":{"headline":"Null dereference in JavaScript::Minifier::XS","id":"CVE-2026-56017"},"packages":[{"ecosystem":"openSUSE:Tumbleweed","fixed":["4.490.0-1.1"],"introduced":["0"],"last_affected":[],"package":"perl-CGI-Session","purl":"pkg:rpm/opensuse/perl-CGI-Session\u0026distro=openSUSE%20Tumbleweed","source":"openSUSE-SU-2026:11168-1"}],"prev":{"headline":"Net::IP::LPM versions before 1.11 for Perl allow a heap out-of-bounds read via an unbounded prefix length","id":"CVE-2026-56015"},"products":["CGI::Session::ID::md5"],"published":"2026-07-01","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-01","vendors":["MARKSTOS"]},"summary":"Attackers can predict session IDs due to low-entropy generation, allowing them to impersonate users and bypass authentication in Perl applications.","url":"https://insights.sbomify.com/CVE-2026-56016/"}