# CVE-2026-56074: PraisonAI - Tool Approval Cache Bypass via Coarse-Grained Caching

> Attackers bypass tool approval prompts in PraisonAI by exploiting coarse-grained caching, enabling silent execution of malicious commands to steal credentials.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:P/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-ffp3-3562-8cv3, PYSEC-2026-2946

## What is CVE-2026-56074?

CVE-2026-56074 is a medium-severity vulnerability in PraisonAI, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

PraisonAI before 1.5.128 caches tool approval decisions by tool name only, not by invocation arguments, allowing subsequent execute_command calls to bypass approval prompts. Attackers can exploit this by obtaining initial approval for a benign command, then silently exfiltrate API keys and credentials via subsequent shell commands without user consent.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-56074?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 4.5.128 |
| `praisonaiagents` | PyPI | All versions | 4.5.128 |
| `praisonaiagents` | PyPI | All versions | 4.5.128 |

## How do I fix CVE-2026-56074?

Upgrade praisonaiagents to 4.5.128 or later.

## Is CVE-2026-56074 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56074 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56074 and fix it if it is affected.

What it is: CVE-2026-56074 is a medium-severity vulnerability in PraisonAI, published on 18 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56074 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 4.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 4.5.128
- praisonaiagents (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56074/ (Markdown: https://insights.sbomify.com/CVE-2026-56074/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56074
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56074
- OSV: https://osv.dev/vulnerability/CVE-2026-56074

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56074/
Summaries are generated and may contain mistakes; the official description above is the record.
