# CVE-2026-56075: PraisonAI - Arbitrary Shell Command Execution via Hardcoded Approval Mode Override

> Authenticated attackers can execute arbitrary shell commands by bypassing approval gates in PraisonAI, leading to remote code execution.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 18 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-gx4r-3wg8-9w5x, GHSA-qwgj-rrpj-75xm

## What is CVE-2026-56075?

CVE-2026-56075 is a high-severity command injection vulnerability in PraisonAI, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI before 4.5.128 contains an arbitrary shell command execution vulnerability where the UI modules hardcode approval_mode to auto, overriding administrator configuration from PRAISON_APPROVAL_MODE environment variable. Authenticated attackers can instruct the LLM agent to execute arbitrary shell commands via subprocess.run with shell=True, bypassing the manual approval gate and insufficient command sanitization blocklists.

Weakness: CWE-863 (Incorrect Authorization)

## Which versions are affected by CVE-2026-56075?

2 open source packages ship an affected version, including PraisonAI and praisonai.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `PraisonAI` | PyPI | All versions | 4.5.128 |
| `praisonai` | PyPI | All versions | 4.5.128 |

## How do I fix CVE-2026-56075?

Upgrade PraisonAI to 4.5.128 or later.

## Is CVE-2026-56075 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56075 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56075 and fix it if it is affected.

What it is: CVE-2026-56075 is a high-severity command injection vulnerability in PraisonAI, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56075 exists.

Affected packages and fixed versions:
- PraisonAI (PyPI): affected all versions; fixed in 4.5.128
- praisonai (PyPI): affected all versions; fixed in 4.5.128

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56075/ (Markdown: https://insights.sbomify.com/CVE-2026-56075/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56075
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56075
- OSV: https://osv.dev/vulnerability/CVE-2026-56075

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56075/
Summaries are generated and may contain mistakes; the official description above is the record.
