# CVE-2026-56078: PraisonAI - Arbitrary File Read and Write via Path Traversal in MultiAgentMonitor

> Attackers can read, write, or overwrite arbitrary files via path traversal in PraisonAI, potentially leading to code execution or data disclosure.

- **Severity:** High 8.7 (`CVSS:4.0/AV:N/AC:L/AT:N/PR:L/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 18 Jun 2026
- **Updated:** 22 Jun 2026
- **Also known as:** GHSA-766v-q9x3-g744, PYSEC-2026-2943

## What is CVE-2026-56078?

CVE-2026-56078 is a high-severity path traversal vulnerability in PraisonAI, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

PraisonAI before 1.5.115 contains a path traversal vulnerability in MultiAgentMonitor that fails to sanitize agent IDs when building file paths. Attackers can include traversal sequences like ../ in agent IDs to read, write, or overwrite arbitrary files, enabling sensitive disclosure, denial of service, or code execution.

Weakness: CWE-22 (Improper Limitation of a Pathname to a Restricted Directory)

## Which versions are affected by CVE-2026-56078?

3 open source packages ship an affected version, including praisonaiagents.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |
| `praisonaiagents` | PyPI | All versions | 1.5.115 |

## How do I fix CVE-2026-56078?

Upgrade praisonaiagents to 1.5.115 or later.

## Is CVE-2026-56078 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56078 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56078 and fix it if it is affected.

What it is: CVE-2026-56078 is a high-severity path traversal vulnerability in PraisonAI, published on 18 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56078 exists.

Affected packages and fixed versions:
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115
- praisonaiagents (PyPI): affected all versions; fixed in 1.5.115

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56078/ (Markdown: https://insights.sbomify.com/CVE-2026-56078/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56078
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56078
- OSV: https://osv.dev/vulnerability/CVE-2026-56078

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56078/
Summaries are generated and may contain mistakes; the official description above is the record.
