# CVE-2026-56104: Chainlit < 2.10.1 Session Hijacking via WebSocket Session Restoration

> Unauthenticated attackers can hijack user sessions via WebSocket restoration, gaining unauthorized access to tools and data.

- **Severity:** High 8.8 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:N/VC:H/VI:H/VA:N/SC:H/SI:H/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** Yes
- **Published:** 22 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-c39v-8hrw-h448, PYSEC-2026-4028

## What is CVE-2026-56104?

CVE-2026-56104 is a high-severity authentication bypass vulnerability in chainlit, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.

### Official description

Chainlit before 2.10.1 contains a session hijacking vulnerability that allows unauthenticated attackers to restore and inherit authenticated user sessions by presenting a valid sessionId during WebSocket session restoration without ownership verification. Attackers can exploit the restore_existing_session path to assume a victim's permissions and roles, enabling unauthorized invocation of tools and access to data restricted to the authenticated victim.

Weakness: CWE-862 (Missing Authorization)

## Which versions are affected by CVE-2026-56104?

3 open source packages ship an affected version, including chainlit.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `chainlit` | PyPI | All versions | 2.10.1 |
| `chainlit` | PyPI | All versions | 2.10.1 |
| `chainlit` | PyPI | All versions | 2.10.1 |

## How do I fix CVE-2026-56104?

Upgrade chainlit to 2.10.1 or later.

## Is CVE-2026-56104 being exploited?

There is no known exploitation of CVE-2026-56104 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56104 and fix it if it is affected.

What it is: CVE-2026-56104 is a high-severity authentication bypass vulnerability in chainlit, published on 22 Jun 2026. Any signed-in user can exploit it over the network, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56104 in the wild and no public exploit code.

Affected packages and fixed versions:
- chainlit (PyPI): affected all versions; fixed in 2.10.1
- chainlit (PyPI): affected all versions; fixed in 2.10.1
- chainlit (PyPI): affected all versions; fixed in 2.10.1

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56104/ (Markdown: https://insights.sbomify.com/CVE-2026-56104/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56104
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56104
- OSV: https://osv.dev/vulnerability/CVE-2026-56104

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56104/
Summaries are generated and may contain mistakes; the official description above is the record.
