{"answers":{"affected":"","exploited":"There is no known exploitation of CVE-2026-56109 in the wild and no public exploit code.","fix":"Upgrade to a fixed version.","what":"CVE-2026-56109 is a high-severity use after free vulnerability in alsa-project alsa-lib, published on 22 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim."},"fix_prompt":"Check this codebase for CVE-2026-56109 and fix it if it is affected.\n\nWhat it is: CVE-2026-56109 is a high-severity use after free vulnerability in alsa-project alsa-lib, published on 22 Jun 2026. It can only be exploited from the same machine or local network, with no action from the victim.\nExploitation: There is no known exploitation of CVE-2026-56109 in the wild and no public exploit code.\n\nAffected product: alsa-project alsa-lib. No package-level version data is available, so check the vendor advisory linked from the reference page.\n\nTask:\n1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.\n2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.\n3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.\n4. Run the tests and summarise what changed and why.\n5. If nothing in the project is affected, say so and change nothing.\n\nReference: https://insights.sbomify.com/CVE-2026-56109/ (Markdown: https://insights.sbomify.com/CVE-2026-56109/index.md)","id":"CVE-2026-56109","markdown":"https://insights.sbomify.com/CVE-2026-56109/index.md","name":"CVE-2026-56109","record":{"aliases":["AZL-90204","BELL-CVE-2026-56109","DEBIAN-CVE-2026-56109","ECHO-00b6-a8a9-0340","GHSA-jfrh-w252-q2h4","MINI-c9hx-vj2q-7822","OESA-2026-2847","OESA-2026-2848","OESA-2026-2849","OESA-2026-2850","ROOT-OS-ALPINE-324-CVE-2026-56109","SUSE-SU-2026:22291-1","SUSE-SU-2026:22381-1","SUSE-SU-2026:22667-1","SUSE-SU-2026:2885-1","SUSE-SU-2026:3270-1","SUSE-SU-2026:3492-1","UBUNTU-CVE-2026-56109","USN-8538-1","openSUSE-SU-2026:21075-1"],"analysis":{"component_type":"library","fix_type":"upgrade","impacts":["code_execution","denial_of_service"],"network_reachable":"adjacent_or_local","non_default_config":false,"product_category":"ALSA audio library","requires_auth":"none","summary":"Attackers can corrupt memory and potentially execute code or cause denial of service by supplying maliciously crafted ALSA configuration text to the library.","user_interaction":"not_required","vuln_class":"use_after_free"},"analysis_generated_by":"qwen3.8-flash-next","assigner":"VulnCheck","cpe":[],"cvss":{"score":7,"severity":"high","source":"cna","vector":"CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:L/VA:H/SC:N/SI:N/SA:N","version":"4.0"},"cwes":[{"id":"CWE-415","name":"Double Free"}],"description":"The Advanced Linux Sound Architecture (ALSA) library before 1.2.16.1 contains a double-free vulnerability in parse_def() in src/conf.c that allows attackers to corrupt memory by supplying maliciously crafted ALSA configuration text. When parsing nested compound or array configuration blocks, parse_def() fails to check return values before continuing, causing snd_config_delete() to be called twice on the same already-freed node, resulting in a NULL-pointer write or invalid memory read.","ecosystems":["SUSE:Linux Enterprise Micro 5.3","SUSE:Linux Enterprise Micro 5.4","SUSE:Linux Enterprise Micro 5.5","SUSE:Linux Enterprise Module for Basesystem 15 SP7","SUSE:Linux Enterprise Server 16.0","SUSE:Linux Enterprise Server for SAP applications 16.0","SUSE:Linux Micro 6.1","SUSE:Linux Micro 6.2","openSUSE:Leap 16.0"],"exploits":{"exploitdb":0,"first_seen":null,"github_poc":0,"max_poc_stars":null,"metasploit":0,"nuclei":0,"refs":[],"tier":"none_known"},"has_fix":true,"headline":"ALSA Library \u003c 1.2.16.1 Double-Free via parse_def() in conf.c","id":"CVE-2026-56109","indexable":true,"kev":null,"kind":"cve","links":{"ecosystem":null,"product":null,"products":[],"type":"use_after_free","year":"2026"},"n_packages":9,"n_references":4,"next":{"headline":"Marlin Firmware 2.1.2.7 Out-of-Bounds Write via M421 G-code Handler","id":"CVE-2026-56111"},"packages":[{"ecosystem":"SUSE:Linux Enterprise Micro 5.3","fixed":["1.2.6.1-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.3","source":"SUSE-SU-2026:2885-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.4","fixed":["1.2.6.1-150400.3.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.4","source":"SUSE-SU-2026:2885-1"},{"ecosystem":"SUSE:Linux Enterprise Micro 5.5","fixed":["1.2.8-150500.3.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Micro%205.5","source":"SUSE-SU-2026:3492-1"},{"ecosystem":"SUSE:Linux Enterprise Module for Basesystem 15 SP7","fixed":["1.2.10-150600.4.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Module%20for%20Basesystem%2015%20SP7","source":"SUSE-SU-2026:3270-1"},{"ecosystem":"SUSE:Linux Enterprise Server 16.0","fixed":["1.2.14-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Server%2016.0","source":"SUSE-SU-2026:22381-1"},{"ecosystem":"SUSE:Linux Enterprise Server for SAP applications 16.0","fixed":["1.2.14-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Enterprise%20Server%20for%20SAP%20applications%2016.0","source":"SUSE-SU-2026:22381-1"},{"ecosystem":"SUSE:Linux Micro 6.1","fixed":["1.2.10-slfo.1.1_2.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Micro%206.1","source":"SUSE-SU-2026:22667-1"},{"ecosystem":"SUSE:Linux Micro 6.2","fixed":["1.2.14-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/suse/alsa\u0026distro=SUSE%20Linux%20Micro%206.2","source":"SUSE-SU-2026:22291-1"},{"ecosystem":"openSUSE:Leap 16.0","fixed":["1.2.14-160000.3.1"],"introduced":["0"],"last_affected":[],"package":"alsa","purl":"pkg:rpm/opensuse/alsa\u0026distro=openSUSE%20Leap%2016.0","source":"openSUSE-SU-2026:21075-1"}],"prev":{"headline":"Chainlit \u003c 2.10.1 Session Hijacking via WebSocket Session Restoration","id":"CVE-2026-56104"},"products":["alsa-lib"],"published":"2026-06-22","related":[],"sources":[{"class":"attribution","licence":"CVE Terms of Use (MITRE)","name":"CVE List","prefix":"CVE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"SUSE"},{"class":"attribution","licence":"CC BY 4.0","name":"SUSE","prefix":"openSUSE"},{"class":"attribution","licence":"CWE Terms of Use","name":"CWE (MITRE)"},{"class":"attribution","licence":"FIRST CVSS licence","name":"CVSS (FIRST)"}],"ssvc":{"automatable":"no","exploitation":"none","technical_impact":"partial"},"state":"PUBLISHED","updated":"2026-07-14","vendors":["alsa-project"]},"summary":"Attackers can corrupt memory and potentially execute code or cause denial of service by supplying maliciously crafted ALSA configuration text to the library.","url":"https://insights.sbomify.com/CVE-2026-56109/"}