CVE-2026-56130 Apache Shiro: Remember-me cookie isn't checked for expiry on the server

Low 2.0 Published Updated

Attackers can reuse expired remember-me cookies to maintain unauthorized access if the feature is enabled.

Exploited in the wild
Not known
Login needed
Any signed-in user
Attackable
Over the internet
Victim action needed
A user has to click or open something
Fix
None listed

What is CVE-2026-56130?

CVE-2026-56130 is a low-severity authentication bypass vulnerability in Apache Shiro, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

Official description

"Remember me" cookie age is not verified on the server. This potentially allows an attacker to intercept a valid cookie and reuse it indefinitely, even after the configured expiration time has passed. This issue affects all Apache Shiro versions from 1.2.4 through 2.x, and 3.0.0-alpha-1, only when RememberMe functionality is enabled.

Upgrade to version 3.0.0 or later, which fixes the issue.

Weakness: CWE-294

Which versions are affected by CVE-2026-56130?

How do I fix CVE-2026-56130?

No fix has been published for CVE-2026-56130 yet. Limit exposure of the affected software until one is available.

Upgrade, and rotate credentials and sessions that may have been exposed. More about Authentication bypass.

Is CVE-2026-56130 being exploited?

There is no known exploitation of CVE-2026-56130 in the wild and no public exploit code.

Sources

Also known as DEBIAN-CVE-2026-56130, GHSA-m8g6-vrr2-x7ff, UBUNTU-CVE-2026-56130.

Is CVE-2026-56130 in your software?

Upload an SBOM and sbomify checks it against every vulnerability here, every day.

Check your SBOMs for free