# CVE-2026-56130: Apache Shiro: Remember-me cookie isn't checked for expiry on the server

> Attackers can reuse expired remember-me cookies to maintain unauthorized access if the feature is enabled.

- **Severity:** Low 2.0 (`CVSS:4.0/AV:N/AC:H/AT:N/PR:L/UI:A/VC:L/VI:N/VA:N/SC:L/SI:N/SA:N/S:N/AU:Y/V:D/RE:L/U:Green`)
- **Exploited in the wild:** Not known
- **Login needed:** Any signed-in user
- **Attackable:** Over the internet
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 25 Jun 2026
- **Updated:** 25 Jun 2026
- **Also known as:** DEBIAN-CVE-2026-56130, GHSA-m8g6-vrr2-x7ff, UBUNTU-CVE-2026-56130

## What is CVE-2026-56130?

CVE-2026-56130 is a low-severity authentication bypass vulnerability in Apache Shiro, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.

### Official description

"Remember me" cookie age is not verified on the server. This potentially allows an attacker to intercept a valid cookie and reuse it indefinitely, even after the configured expiration time has passed.
This issue affects all Apache Shiro versions from 1.2.4 through 2.x, and 3.0.0-alpha-1, only when RememberMe functionality is enabled.

Upgrade to version 3.0.0 or later, which fixes the issue.

Weakness: CWE-294 (Authentication Bypass by Capture-replay)

## Which versions are affected by CVE-2026-56130?


## How do I fix CVE-2026-56130?

No fix has been published for CVE-2026-56130 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56130 being exploited?

There is no known exploitation of CVE-2026-56130 in the wild and no public exploit code.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56130 and fix it if it is affected.

What it is: CVE-2026-56130 is a low-severity authentication bypass vulnerability in Apache Shiro, published on 25 Jun 2026. Any signed-in user can exploit it over the network, and only if a user opens a file or follows a link.
Exploitation: There is no known exploitation of CVE-2026-56130 in the wild and no public exploit code.

Affected product: Apache Shiro. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56130/ (Markdown: https://insights.sbomify.com/CVE-2026-56130/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56130
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56130
- OSV: https://osv.dev/vulnerability/CVE-2026-56130

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56130/
Summaries are generated and may contain mistakes; the official description above is the record.
