# CVE-2026-56207: Apache Impala: SAML authentication bypass via forged bearer token

> Attackers can bypass SAML authentication in Apache Impala by forging bearer tokens, allowing them to impersonate other users and escalate privileges.

- **Severity:** Critical 9.8 (`CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 9 Sep 2026
- **Updated:** 10 Sep 2026
- **Also known as:** GHSA-3mmv-f538-2fpw

## What is CVE-2026-56207?

CVE-2026-56207 is a critical authentication bypass vulnerability in Apache Impala, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.

### Official description

Signature of Bearer token is not verified in last step of SAML2 authentication for Impala's hs2-http interface, allowing altering user name and acting as another user.

This issue affects Apache Impala: >=4.0.0.

Users are recommended to upgrade to version 4.5.2, which fixes this issue.

Weakness: CWE-347 (Improper Verification of Cryptographic Signature)

## Which versions are affected by CVE-2026-56207?

It affects 1 product.


Products: Apache Impala.

## How do I fix CVE-2026-56207?

No fix has been published for CVE-2026-56207 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-56207 being exploited?

There is no known exploitation of CVE-2026-56207 in the wild and no public exploit code.

## Other vulnerabilities in Apache Impala

- [CVE-2018-11792](https://insights.sbomify.com/CVE-2018-11792/): Privilege escalation in Apache Impala (critical 9.8)
- [CVE-2017-5640](https://insights.sbomify.com/CVE-2017-5640/): Auth bypass in Apache Impala (critical 9.8)
- [CVE-2026-57866](https://insights.sbomify.com/CVE-2026-57866/): Apache Impala: Secrets Exfiltration via SSRF (high 8.8)
- [CVE-2026-65181](https://insights.sbomify.com/CVE-2026-65181/): Apache Impala: RCE via External Data Source Class Loading (high 8.1)
- [CVE-2021-28131](https://insights.sbomify.com/CVE-2021-28131/): Impala logs contain secrets (high 7.5)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56207 and fix it if it is affected.

What it is: CVE-2026-56207 is a critical authentication bypass vulnerability in Apache Impala, published on 9 Sep 2026. An attacker can exploit it over the internet without logging in, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-56207 in the wild and no public exploit code.

Affected product: Apache Impala. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56207/ (Markdown: https://insights.sbomify.com/CVE-2026-56207/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56207
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56207
- OSV: https://osv.dev/vulnerability/CVE-2026-56207

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56207/
Summaries are generated and may contain mistakes; the official description above is the record.
