# CVE-2026-56236: Capgo CLI - Arbitrary File Overwrite via Symlink-Following in Local Credential Operations

> Attackers can overwrite arbitrary files or expose credentials via malicious symlinks when developers run the Capgo CLI.

- **Severity:** Medium 6.8 (`CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:A/VC:L/VI:H/VA:N/SC:N/SI:N/SA:N`)
- **Exploited in the wild:** Not known
- **Login needed:** Not needed
- **Attackable:** Local or same network only
- **Victim action needed:** A user has to click or open something
- **Fix available:** No
- **Published:** 21 Jun 2026
- **Updated:** 8 Oct 2026
- **Also known as:** GHSA-4ch8-prch-6prf, GHSA-8mpm-q7mh-8fvh

## What is CVE-2026-56236?

CVE-2026-56236 is a medium-severity path traversal vulnerability in capgo cli, published on 21 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.

### Official description

Capgo CLI before 12.128.2 contains arbitrary file overwrite vulnerabilities in login and build credentials operations that follow symlinks without validation. Attackers can create malicious symlinks in repositories to overwrite arbitrary files or expose credentials with world-readable permissions when developers run the CLI.

Weakness: CWE-59 (Improper Link Resolution Before File Access)

## Which versions are affected by CVE-2026-56236?

2 open source packages ship an affected version, including @capgo/cli.


| Package | Ecosystem | Affected | Fixed in |
| --- | --- | --- | --- |
| `@capgo/cli` | npm | All versions | 7.84.6 |
| `@capgo/cli` | npm | All versions | 7.84.6 |

## How do I fix CVE-2026-56236?

Upgrade @capgo/cli to 7.84.6 or later.

## Is CVE-2026-56236 being exploited?

It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56236 exists.

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-56236 and fix it if it is affected.

What it is: CVE-2026-56236 is a medium-severity path traversal vulnerability in capgo cli, published on 21 Jun 2026. It can only be exploited from the same machine or local network, and only if a user opens a file or follows a link.
Exploitation: It is not confirmed as exploited in the wild, but public exploit code for CVE-2026-56236 exists.

Affected packages and fixed versions:
- @capgo/cli (npm): affected all versions; fixed in 7.84.6
- @capgo/cli (npm): affected all versions; fixed in 7.84.6

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-56236/ (Markdown: https://insights.sbomify.com/CVE-2026-56236/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-56236
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-56236
- OSV: https://osv.dev/vulnerability/CVE-2026-56236

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-56236/
Summaries are generated and may contain mistakes; the official description above is the record.
