# CVE-2026-5627: Path Traversal in mintplex-labs/anything-llm

> Attackers can exploit path traversal in AgentFlows to read sensitive configuration files or delete critical server files, impacting confidentiality and availability.

- **Severity:** Critical 9.1 (`CVSS:3.0/AV:N/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H`)
- **Exploited in the wild:** Not known
- **Login needed:** An administrator
- **Attackable:** Over the internet
- **Victim action needed:** Not needed
- **Fix available:** No
- **Published:** 7 Apr 2026
- **Updated:** 7 Apr 2026
- **Also known as:** GHSA-3593-xf56-f85v

## What is CVE-2026-5627?

CVE-2026-5627 is a critical path traversal vulnerability in Mintplexlabs Anythingllm, published on 7 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.

### Official description

A path traversal vulnerability exists in mintplex-labs/anything-llm versions up to and including 1.9.1, within the `AgentFlows` component. The vulnerability arises from improper handling of user input in the `loadFlow` and `deleteFlow` methods in `server/utils/agentFlows/index.js`. Specifically, the combination of `path.join` and `normalizePath` allows attackers to bypass directory restrictions and access or delete arbitrary `.json` files on the server. This can lead to information disclosure, such as leaking sensitive configuration files containing API keys, or denial of service by deleting critical files like `package.json`. The issue is resolved in version 1.12.1.

Weakness: CWE-29 (Path Traversal: '\..\filename')

## Which versions are affected by CVE-2026-5627?

It affects 1 product.


Products: Mintplexlabs Anythingllm.

## How do I fix CVE-2026-5627?

No fix has been published for CVE-2026-5627 yet. Limit exposure of the affected software until one is available.

## Is CVE-2026-5627 being exploited?

There is no known exploitation of CVE-2026-5627 in the wild and no public exploit code.

## Other vulnerabilities in Mintplexlabs Anythingllm

- [CVE-2024-3025](https://insights.sbomify.com/CVE-2024-3025/): Path Traversal in mintplex-labs/anything-llm (critical 9.9)
- [CVE-2024-0455](https://insights.sbomify.com/CVE-2024-0455/): SSRF on AWS deployed instances of AnythingLLM via /metadata (critical 9.9)
- [CVE-2026-32626](https://insights.sbomify.com/CVE-2026-32626/): AnythingLLM has a Streaming Phase XSS to RCE via LLM Response Injection (critical 9.7)
- [CVE-2024-3104](https://insights.sbomify.com/CVE-2024-3104/): Remote Code Execution in mintplex-labs/anything-llm (critical 9.6)
- [CVE-2024-3149](https://insights.sbomify.com/CVE-2024-3149/): SSRF in mintplex-labs/anything-llm (critical 9.6)

## Fix prompt for AI coding agents

```text
Check this codebase for CVE-2026-5627 and fix it if it is affected.

What it is: CVE-2026-5627 is a critical path traversal vulnerability in Mintplexlabs Anythingllm, published on 7 Apr 2026. An attacker needs administrator access to exploit it, with no action from the victim.
Exploitation: There is no known exploitation of CVE-2026-5627 in the wild and no public exploit code.

Affected product: Mintplexlabs Anythingllm. No package-level version data is available, so check the vendor advisory linked from the reference page.

Task:
1. Search the dependency manifests and lockfiles (for example package.json, package-lock.json, requirements.txt, poetry.lock, uv.lock, pom.xml, build.gradle, go.mod, Cargo.lock, Gemfile.lock) and any Dockerfiles for the affected packages, including transitive dependencies.
2. If an affected version is in use, upgrade it to the fixed version for its release line with the project's package manager, so the lockfile is regenerated. Prefer the smallest upgrade that fixes it.
3. If there is no fix, or the upgrade would break the build, do not guess: explain the risk and the safest workaround instead.
4. Run the tests and summarise what changed and why.
5. If nothing in the project is affected, say so and change nothing.

Reference: https://insights.sbomify.com/CVE-2026-5627/ (Markdown: https://insights.sbomify.com/CVE-2026-5627/index.md)
```

## Sources

- CVE record: https://www.cve.org/CVERecord?id=CVE-2026-5627
- NVD: https://nvd.nist.gov/vuln/detail/CVE-2026-5627
- OSV: https://osv.dev/vulnerability/CVE-2026-5627

---
From sbomify Insights: https://insights.sbomify.com/CVE-2026-5627/
Summaries are generated and may contain mistakes; the official description above is the record.
